[U-Boot] arm, i2c: added support for the TWSI I2C Interface

Heiko Schocher hs at denx.de
Thu Jul 16 13:09:20 CEST 2009


Hello Prafulla,

Prafulla Wadaskar wrote:
>> -----Original Message-----
>> From: Heiko Schocher [mailto:hs at denx.de] 
>> Sent: Thursday, July 16, 2009 3:47 PM
>> To: Prafulla Wadaskar
>> Cc: Jean-Christophe PLAGNIOL-VILLARD; U-Boot user list
>> Subject: Re: arm, i2c: added support for the TWSI I2C Interface
>>
>> Hello Prafulla,
>>
>> Prafulla Wadaskar wrote:
>>>> -----Original Message-----
>>>> From: Heiko Schocher [mailto:hs at denx.de]
>>>> Sent: Thursday, July 16, 2009 3:34 PM
>>>> To: Prafulla Wadaskar
>>>> Cc: Jean-Christophe PLAGNIOL-VILLARD; U-Boot user list
>>>> Subject: Re: arm, i2c: added support for the TWSI I2C Interface
>>>>
>>>> Hello Prafulla,
>>>>
>>>> Prafulla Wadaskar wrote:
>>>>>> -----Original Message-----
>>>>>> From: Heiko Schocher [mailto:hs at denx.de]
>>>>>> Sent: Thursday, July 16, 2009 1:31 PM
>>>>>> To: Jean-Christophe PLAGNIOL-VILLARD; Prafulla Wadaskar
>>>>>> Cc: U-Boot user list
>>>>>> Subject: arm, i2c: added support for the TWSI I2C Interface
>>>>>>
>>>>>> added support for the Hardware I2C TWSI Interface on 
>> kirkwood SOCs, 
>>>>>> based on the Linux driver, without IRQ support.
>>>>>>
>>>>>> Tested on a ARM926EJS (CPU Core Version FEROCEON_88FR131 SOC 
>>>>>> Family: KIRKWOOD, KW88F6281) based suen3 board
>>>>>>
>>>>>> Signed-off-by: Heiko Schocher <hs at denx.de>
>>>>>> ---
>>>>>>  drivers/i2c/Makefile      |    1 +
>>>>>>  drivers/i2c/mv64xxx-i2c.c |  452
>>>>> Can you rename this? 
>>>> Of course, what name do you prefer?
>>> I will prefer a name kirkwood_i2c.c
>> Hmm.. I thought twsi_i2c.c ...
> #include <asm/arch/Kirkwood.h> in your file indicate it is kirkwood low level driver
> If you wish twsi_i2c.c is more generic name, but in that case you need to abstract arch specific support well.

I have no idea, how generic this driver is, so I vote for
naming it in the first step as kirkwood_i2c.c as you suggested.
(Because I could not test it on another plattform)

If someone use it on another plattforms, we can do this step
later.

>>>>>> +++++++++++++++++++++++++++++++++++++++++++++
>>>>>>  2 files changed, 453 insertions(+), 0 deletions(-)  create mode 
>>>>>> 100644 drivers/i2c/mv64xxx-i2c.c
>>>>>>
>>>>>> diff --git a/drivers/i2c/Makefile b/drivers/i2c/Makefile index 
>>>>>> ef32f13..ce30111 100644
>>>>>> --- a/drivers/i2c/Makefile
>>>>>> +++ b/drivers/i2c/Makefile
>>>>>> @@ -33,6 +33,7 @@ COBJS-$(CONFIG_DRIVER_OMAP1510_I2C) += 
>>>>>> omap1510_i2c.o
>>>>>>  COBJS-$(CONFIG_DRIVER_OMAP24XX_I2C) += omap24xx_i2c.o
>>>>>>  COBJS-$(CONFIG_DRIVER_OMAP34XX_I2C) += omap24xx_i2c.o
>>>>>>  COBJS-$(CONFIG_DRIVER_S3C24X0_I2C) += s3c24x0_i2c.o
>>>>>> +COBJS-$(CONFIG_I2C_MV64xxx) += mv64xxx-i2c.o
>>>>> Put this in order
>>>> What do you mean?
>>> Arrange them in alphabetical order, insert this line between "l" "m"
>> I think the "alphabetical order" is for the CONFIG_ defines ...
>> so I used the right place for it ... but, if I rename this 
>> define in CONFIG_DRIVER_I2C_TWSI, it gets another place (between
>>  COBJS-$(CONFIG_I2C_MXC) += mxc_i2c.o
>> +COBJS-$(CONFIG_DRIVER_I2C_TWSI) += twsi_i2c.o
> Also this could be CONFIG_I2C_KIRKWOOD or CONFIG_I2C_TWSI or CONFIG_TWSI_I2C

Yep KIRKWOOD is what I prefer actual.

thanks
bye
Heiko
-- 
DENX Software Engineering GmbH,     MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany


More information about the U-Boot mailing list