[U-Boot] [PATCH] omap3evm: Clean-up EVM detection code.
Albert ARIBAUD
albert.aribaud at free.fr
Thu Dec 2 12:56:27 CET 2010
Le 02/12/2010 12:37, Wolfgang Denk a écrit :
> Dear Sanjeev Premi,
>
> In message<1291288812-12653-1-git-send-email-premi at ti.com> you wrote:
>> This patch does following changes:
>> * Change the type (u8 -> int) for omap3_evm_version.
>> * Introduce an 'undefined' board revision for init
>> value.
>> * Use of #define instead of magic numbers
>>
>> Signed-off-by: Sanjeev Premi<premi at ti.com>
>> ---
>> board/ti/evm/evm.c | 39 +++++++++++++++++++++++----------------
>> board/ti/evm/evm.h | 17 +++++++----------
>> 2 files changed, 30 insertions(+), 26 deletions(-)
>>
>> diff --git a/board/ti/evm/evm.c b/board/ti/evm/evm.c
>> index 09d14f7..8d9ce73 100644
>> --- a/board/ti/evm/evm.c
>> +++ b/board/ti/evm/evm.c
>> @@ -37,36 +37,43 @@
>> #include<asm/mach-types.h>
>> #include "evm.h"
>>
>> -static u8 omap3_evm_version;
>> +static int omap3_evm_version = OMAP3EVM_BOARD_UNDEF;
> ...
>> +#define OMAP3EVM_BOARD_UNDEF -1 /* EVM revision not detected */
>
> Sorry, but I will not accept this patch.
>
> The only purpose of this initialization with a non-zero value is to
> paper over a problem. As a result, the problem will be left unsolved,
> so it bites us again elsewhere, and we increase the memory footprint
> of the U-Boot image without need.
>
> NAK.
Note that initialization should be unnecessary if the static variable is
int rather than u8.
> Best regards,
>
> Wolfgang Denk
Amicalement,
--
Albert.
More information about the U-Boot
mailing list