[U-Boot] [PATCH v2] fdt: Add fdt_del_node_and_alias helper

Gerald Van Baren vanbaren at cideas.com
Wed Mar 31 00:20:50 CEST 2010


Hi Kumar,

Kumar Gala wrote:
> Add a helper function that given an alias will delete both the node
> the alias points to and the alias itself
> 
> Signed-off-by: Kumar Gala <galak at kernel.crashing.org>

I assume you will want to apply this with the 8xxx patch that uses it, so...

Acked-by: Gerald Van Baren <vanbaren at cideas.com>

> ---
> * Make alias param const
> 
>  common/fdt_support.c  |   13 +++++++++++++
>  include/fdt_support.h |    2 ++
>  2 files changed, 15 insertions(+), 0 deletions(-)
> 
> diff --git a/common/fdt_support.c b/common/fdt_support.c
> index f89a3ee..0d0f513 100644
> --- a/common/fdt_support.c
> +++ b/common/fdt_support.c
> @@ -757,3 +757,16 @@ int fdt_fixup_nor_flash_size(void *blob, int cs, u32 size)
>  	return -1;
>  }
>  #endif
> +
> +void fdt_del_node_and_alias(void *blob, const char *alias)
> +{
> +	int off = fdt_path_offset(blob, alias);
> +
> +	if (off < 0)
> +		return;
> +
> +	fdt_del_node(blob, off);
> +
> +	off = fdt_path_offset(blob, "/aliases");
> +	fdt_delprop(blob, off, alias);
> +}
> diff --git a/include/fdt_support.h b/include/fdt_support.h
> index 0a9dd0d..5388c29 100644
> --- a/include/fdt_support.h
> +++ b/include/fdt_support.h
> @@ -81,5 +81,7 @@ int fdt_resize(void *blob);
>  
>  int fdt_fixup_nor_flash_size(void *blob, int cs, u32 size);
>  
> +void fdt_del_node_and_alias(void *blob, const char *alias);
> +
>  #endif /* ifdef CONFIG_OF_LIBFDT */
>  #endif /* ifndef __FDT_SUPPORT_H */



More information about the U-Boot mailing list