[U-Boot] [PATCH 09/21] PXA: Voipac270 improvements
Wolfgang Denk
wd at denx.de
Mon Oct 18 20:04:35 CEST 2010
Dear Marek Vasut,
In message <1287257810-23609-10-git-send-email-marek.vasut at gmail.com> you wrote:
> 128MB NOR module support.
> Define __io to get harddrive working.
> Fix saving of environment into OneNAND.
> Boot from harddrive when possible.
> Add missing MAINTAINERS entry.
...
> diff --git a/Makefile b/Makefile
> index 000ad56..0d2d34a 100644
> --- a/Makefile
> +++ b/Makefile
> @@ -1020,13 +1020,18 @@ trizepsiv_config : unconfig
> fi;
> @$(MKCONFIG) -n $@ -a trizepsiv arm pxa trizepsiv
>
> -vpac270_nor_config \
> +vpac270_nor_256M_config \
> +vpac270_nor_128M_config \
> vpac270_onenand_config : unconfig
> @mkdir -p $(obj)include
> @if [ "$(findstring onenand,$@)" ] ; then \
> echo "#define CONFIG_ONENAND_U_BOOT" \
> >>$(obj)include/config.h ; \
> fi;
> + @if [ "$(findstring 256M,$@)" ] ; then \
> + echo "#define CONFIG_256M_U_BOOT" \
> + >>$(obj)include/config.h ; \
> + fi;
> @$(MKCONFIG) -n $@ -a vpac270 arm pxa vpac270
As discussed before: please don't. Use the new options column in
boards.cfg that was added for this very purpose by your own patch.
While doing that, you might want to rebase (as discussed in private
communication) against the Makefile-cleanup branch. Basicly this
means:
- Rename "TEXT_BASE" into "CONFIG_SYS_TEXT_BASE"
- Move the definition of CONFIG_SYS_TEXT_BASE from board/*/config.mk
to include/configs/*.h
- Remove the (now empty) board/*/config.mk files.
[Note: this applies to the other patches as well.]
Best regards,
Wolfgang Denk
--
DENX Software Engineering GmbH, MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: wd at denx.de
"No problem is so formidable that you can't walk away from it."
- C. Schulz
More information about the U-Boot
mailing list