[U-Boot] [PATCH V2 08/11] mtd: nand: supress 'unknown NAND' warning if no nand is found
Steve Sakoman
sakoman at gmail.com
Sun Sep 5 23:37:13 CEST 2010
On Sun, Sep 5, 2010 at 3:59 AM, Sergei Shtylyov <sshtylyov at mvista.com> wrote:
> Hello.
>
> On 02-09-2010 19:33, Steve Sakoman wrote:
>
>> This printk was added recently and results in ugly output on systems
>> with no NAND:
>
>> NAND: nand_get_flash_type: unknown NAND device: Manufacturer ID: 0x00, Chip ID: 0x00 0 MiB
>
>> instead of:
>
>> NAND: 0 MiB
>
>> Signed-off-by: Steve Sakoman<steve at sakoman.com>
>> ---
>> drivers/mtd/nand/nand_base.c | 7 +++++--
>> 1 files changed, 5 insertions(+), 2 deletions(-)
>
>> diff --git a/drivers/mtd/nand/nand_base.c b/drivers/mtd/nand/nand_base.c
>> index ed1c9c9..b2400dd 100644
>> --- a/drivers/mtd/nand/nand_base.c
>> +++ b/drivers/mtd/nand/nand_base.c
>> @@ -2653,8 +2653,11 @@ static struct nand_flash_dev *nand_get_flash_type(struct mtd_info *mtd,
>> }
>>
>> if (!type) {
>> - printk(KERN_INFO "%s: unknown NAND device: Manufacturer ID:"
>> - " 0x%02x, Chip ID: 0x%02x\n", __func__,
>> + /* supress warning if there is no nand */
>> + if ((*maf_id != 0x00) && (*maf_id != 0xff) &&
>> + (dev_id != 0x00) && (dev_id != 0xff))
>
> Parens around != are not necessary.
Understood -- I just think it is easier to read/understand with
parens. If the general consensus is that I should remove them I am
happy to do so.
Steve
More information about the U-Boot
mailing list