[U-Boot] [PATCH 1/2 v3] fdt: Add a do_fixup_by_path_string() function

Scott Wood scottwood at freescale.com
Thu Aug 18 17:14:18 CEST 2011


On 08/17/2011 07:29 PM, Jerry Van Baren wrote:
> Hi Chunhe Lan,
> 
> On 08/17/2011 02:24 AM, Chunhe Lan wrote:
> 
> [snip]
> 
>> +
>> +static inline void do_fixup_by_path_string(void *fdt, const char *path,
>> +                       const char *prop, const char *status)
>> +{
>> +    do_fixup_by_path(fdt, path, prop, status, strlen(status) + 1, 1);
>> +}
>> +
> 
> After all the good advice from Scott et al., the patch turns into a
> pretty trivial one-liner.  I am questioning the advantage of calling
>   do_fixup_by_path_string(fdt, path, prop, status);
> vs. simply calling
>   do_fixup_by_path(fdt, path, prop, status, strlen(status) + 1, 1);
> 
> The do_fixup_by_path_string() saves two parameters
>   "strlen(status) + 1, 1"
> at the cost of Yet Another Function.  Is it worth it?

I think it's a nice convenience, with no runtime cost.  It avoids any
chance of a mismatch between the string passed to do_fixup_by_path and
the string passed to strlen.

More functions versus open-coding is not generally a bad thing.

-Scott



More information about the U-Boot mailing list