[U-Boot] [PATCH v5 05/11] arm, davinci: add support for new spl framework
Heiko Schocher
hs at denx.de
Tue Nov 1 06:06:31 CET 2011
Hello Scott,
Scott Wood wrote:
> On 10/30/2011 11:53 PM, Heiko Schocher wrote:
>> diff --git a/arch/arm/cpu/arm926ejs/davinci/spl_nand.c b/arch/arm/cpu/arm926ejs/davinci/spl_nand.c
>> new file mode 100644
>> index 0000000..efc0521
>> --- /dev/null
>> +++ b/arch/arm/cpu/arm926ejs/davinci/spl_nand.c
>> @@ -0,0 +1,57 @@
[...]
>> +#include <common.h>
>> +#include <nand.h>
>> +#include <asm/io.h>
>
> Does this file use anything from asm/io.h?
removed.
>> +/*
>> + * The main entry for NAND booting. It's necessary that SDRAM is already
>> + * configured and available since this code loads the main U-Boot image
>> + * from NAND into SDRAM and starts it from there.
>> + */
[...]
>> + /*
>> + * Jump to U-Boot image
>> + */
>> + uboot = (void *)CONFIG_SYS_NAND_U_BOOT_START;
>> + (*uboot)();
>> +}
>
> This is common to most NAND SPLs. It would be nice to stick this in a
> common place (at least the loading part, maybe not the jump). Not
> nand_spl_simple.c, as it's utility is not limited to the simple driver.
> Maybe drivers/mtd/nand/nand_spl_load.c?
moved to drivers/mtd/nand/spl_nand_load.c, also I want to let the jump
in this file. I prefer the name "spl_nand_load.c as we have already a
CONFIG_SPL_NAND_SIMPLE -> CONFIG_SPL_NAND_LOAD -> spl_nand_load.c
Is this OK for you?
Shouldn;t we rename nand_spl_simple.c to spl_nand_simple.c also?
bye,
Heiko
--
DENX Software Engineering GmbH, MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
More information about the U-Boot
mailing list