[U-Boot] [RFC PATCH 3/7] reboard: Add generic relocation feature
Mike Frysinger
vapier at gentoo.org
Tue Nov 29 04:07:56 CET 2011
On Monday 21 November 2011 18:57:56 Simon Glass wrote:
> board/Makefile | 45
> board/reloc.c | 101
not to bikeshed, but i don't think we want files in board/. how about
board/common/ or board/generic/ instead ?
> --- /dev/null
> +++ b/board/Makefile
>
> +ifndef CONFIG_SYS_LEGACY_BOARD
> +COBJS += reloc.o
> +endif
i don't think relocation should be tied "legacy board". not all arches do
relocation at all, which means they might never opt in to this aspect.
> --- a/include/common.h
> +++ b/include/common.h
>
> -void relocate_code (ulong, gd_t *, ulong) __attribute__ ((noreturn));
> +#include <reloc.h>
i'd think very few funcs would need this. so maybe we should make the few
places include reloc.h explicitly.
-mike
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 836 bytes
Desc: This is a digitally signed message part.
URL: <http://lists.denx.de/pipermail/u-boot/attachments/20111128/fc74e51a/attachment.pgp>
More information about the U-Boot
mailing list