[U-Boot] [PATCH v4 0/14] Add more framework to OMAP3 SPL, port more boards

Tom Rini tom.rini at gmail.com
Tue Nov 29 22:55:41 CET 2011


On Fri, Nov 18, 2011 at 3:47 PM, Tom Rini <trini at ti.com> wrote:
> Hey all,
>
> This is related to, but a bit different from the RFT thread I made with
> beagleboard SPL patches.  I've incorporated the feedback about splitting
> the changes up a lot more and after talking with Scott Wood on IRC after
> the ML thread, I've created an omap3 specific file with the NAND related
> stuff these boards need (since it would have gotten very big for what's
> really needed here at this stage).  The series is checkpatch.pl clean.
>
> What we have in patches 1-8 is bugfixing and cleanup of the memory code.
> It's worth noting that without these changes we do some very 'funny'
> (read: wrong) things on some platforms like omap3_evm where we find 384MB
> memory when there's really only 256MB (and maybe 256 on the 128MB boards,
> not sure).
>
> Patch 9 adds another hook for SDRC boards to be able to say what timings
> they have because on say beagle or omap3_evm, we have a few choices.  We
> also convert devkit8000 here.
>
> Patch 10 adds a new CONFIG (CONFIG_SPL_OMAP3_ID_NAND) and file so that
> OMAP3 boards which have a PoP chip for NAND/DDR can find out what they are
> and decide on timings based on that.
>
> Patches 11 and 12 convert Beagleboard and OMAP3 EVM to SPL.
>
> Patches 13 and 14 convert the am3517 evm and am3517 crane boards (which
> don't use SDRC but EMIF4) to SPL as well (given Ilya Yanok fixed a bug
> in <asm/arch-omap3/cpu.h> for emif4 this is just a mechanical change).
>
> Changes in v4:
> - Update this to match the feedback I'd incorporated before
> - Update enable_gpmc_cs_config to not use so many magic values
>  and explain the bitshifts.
> - Add MCFG macro to calculate this value for the various DDR chips
>  that are in use.
> - Enhance the comments in <asm/arch-omap3/mem.h> to say to read the
>  TRM to understand what all possible values are and bitshifts and
>  update the comments about rfr_ctrl to explain why they aren't broken
>  into values + shifts.
> - The above three should cover all of Heiko Schocher's feedback.
>
> Changes in v3:
> - Rename CONFIG_SPL_OMAP3_POP_PROBE to CONFIG_SPL_OMAP3_ID_NAND at Igor's
>  request (and function to identify_nand_chip).
> - Drop an unused CONFIG_OMAP3_MICRON_DDR from all of the board config files
>
> Changes in v2:
> - Incorporate Igor Grinberg's feedback (except non-CodingStyle whitespacing).
> - Move to ToT (so omap3_evm patch is reworked a good deal, others that
>  touch <asm/arch-omap3/mem.h> reworked and use new macros when applicable)
> - Fixed a few more typos and hardcoded values to defines while addressing
>  Igor's feedback.

After talking with Wolfgang, this will be merged to u-boot-ti.

-- 
Tom


More information about the U-Boot mailing list