[U-Boot] [PATCH] gpio: remove duplicate function signature
Nikita Kiryanov
nikita at compulab.co.il
Tue Nov 27 10:06:32 CET 2012
gpio_request() appears twice in asm-generic/gpio.h
Remove one of the definitions.
Signed-off-by: Nikita Kiryanov <nikita at compulab.co.il>
---
include/asm-generic/gpio.h | 17 ++++-------------
1 file changed, 4 insertions(+), 13 deletions(-)
diff --git a/include/asm-generic/gpio.h b/include/asm-generic/gpio.h
index 23c9649..bfedbe4 100644
--- a/include/asm-generic/gpio.h
+++ b/include/asm-generic/gpio.h
@@ -42,10 +42,11 @@
*/
/**
- * Request ownership of a GPIO.
+ * Request a gpio. This should be called before any of the other functions
+ * are used on this gpio.
*
- * @param gpio GPIO number
- * @param label Name given to the GPIO
+ * @param gp GPIO number
+ * @param label User label for this GPIO
* @return 0 if ok, -1 on error
*/
int gpio_request(unsigned gpio, const char *label);
@@ -93,14 +94,4 @@ int gpio_get_value(unsigned gpio);
* @return 0 if ok, -1 on error
*/
int gpio_set_value(unsigned gpio, int value);
-
-/**
- * Request a gpio. This should be called before any of the other functions
- * are used on this gpio.
- *
- * @param gp GPIO number
- * @param label User label for this GPIO
- * @return 0 if ok, -1 on error
- */
-int gpio_request(unsigned gpio, const char *label);
#endif /* _ASM_GENERIC_GPIO_H_ */
--
1.7.10.4
More information about the U-Boot
mailing list