[U-Boot] [PATCH 3/3] spi: mpc8xxx_spi: Use DIV_ROUND_UP instead of open-coded

Jagan Teki jagannadh.teki at gmail.com
Tue Aug 6 20:49:54 CEST 2013


On 12-07-2013 15:12, Axel Lin wrote:
> Use DIV_ROUND_UP to simplify the code.
>
> Signed-off-by: Axel Lin <axel.lin at ingics.com>
> ---
>   drivers/spi/mpc8xxx_spi.c | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/spi/mpc8xxx_spi.c b/drivers/spi/mpc8xxx_spi.c
> index 6b0e3b4..c90c0ce 100644
> --- a/drivers/spi/mpc8xxx_spi.c
> +++ b/drivers/spi/mpc8xxx_spi.c
> @@ -93,7 +93,7 @@ int spi_xfer(struct spi_slave *slave, unsigned int bitlen, const void *dout,
>   {
>   	volatile spi8xxx_t *spi = &((immap_t *) (CONFIG_SYS_IMMR))->spi;
>   	unsigned int tmpdout, tmpdin, event;
> -	int numBlks = bitlen / 32 + (bitlen % 32 ? 1 : 0);
> +	int numBlks = DIV_ROUND_UP(bitlen, 32);
>   	int tm, isRead = 0;
>   	unsigned char charSize = 32;
>
>

Reviewed-by: Jagannadha Sutradharudu Teki <jagannadh.teki at gmail.com>

--
Thanks,
Jagan.


More information about the U-Boot mailing list