[U-Boot] [PATCH v5] ARM: mxs: Added application UART driver
Marek Vasut
marex at denx.de
Thu Aug 15 01:24:45 CEST 2013
Dear Andreas Wass,
> The driver makes it possible to use an application UART as
> the U-Boot output console for Freescale i.MX23/i.MX28 devices.
>
> Signed-off-by: Andreas Wass <andreas.wass at dalelven.com>
> Cc: Fabio Estevam <fabio.estevam at freescale.com>
> Cc: Marek Vasut <marex at denx.de>
> ---
> Changes for v2:
> - Added comment that regs-uartapp.h is pulled from LTIB
> - BM_ prefixes removed and _MASK suffixes added instead
> - BP_ prefixes removed and _OFFSET suffixes added instead
> - BF_ defines removed altogether
> - CONFIG_MXS_AUART_CLK renamed to MXS_AUART_CLK and guarding ifndef
> removed - Added comments describing what is set and unset during init of
> driver - Added newline that was accidently removed from serial.c
>
> Changes for v3:
> - All BV_ values are now on the form (value << something)
> - BV_ prefix removed and double underscore substituted with a single
> - File comment of mxs_auart.c now attributes what the driver is based on
> - Uses gd->baudrate instead of CONFIG_BAUDRATE
> - If gd->baudrate is 0 it reverts back to CONFIG_BAUDRATE
> - Checks the validity of the div value calculated when setting the
> baudrate - Magic numbers are now defines instead
> - Cleanup of comments
> - Cleanup of commit message
>
> Changes for v4:
> - Fixed UARTAPP_LINECTRL2_WLEN_*BITS values
>
> Changes for v5:
> - Removed all RSVD values from regs-uartapp.h
> - 0x0000FFFF (and similar) turned into 0xFFFF (and similar)
> - Removed all bitshifts by 0
> - All masks with non-zero shifting are now on the form (value << shift)
>
> arch/arm/include/asm/arch-mxs/regs-uartapp.h | 220
> +++++++++++++++++++++++++++ drivers/serial/Makefile |
> 1 +
> drivers/serial/mxs_auart.c | 151 ++++++++++++++++++
> drivers/serial/serial.c | 2 +
> 4 files changed, 374 insertions(+)
> create mode 100644 arch/arm/include/asm/arch-mxs/regs-uartapp.h
> create mode 100644 drivers/serial/mxs_auart.c
Acked-by: Marek Vasut <marex at denx.de>
Best regards,
Marek Vasut
More information about the U-Boot
mailing list