[U-Boot] [PATCH 3/4 V3] S5P: Rename GPIO definitions
Simon Glass
sjg at chromium.org
Fri Feb 8 17:04:26 CET 2013
Hi Rajeshwari,
On Thu, Feb 7, 2013 at 4:00 AM, Rajeshwari Shinde
<rajeshwari.s at samsung.com> wrote:
> This patch rename GPIO definitions from GPIO_... to S5P_GPIO_...
> This changes was done to enable cmd_gpio for EXYNOS and
> cmd_gpio has GPIO_INPUT same as s5p_gpio driver and hence
> getting a error during compilation.
>
> Build tested for s5p_goni, origen, smdk5250, s5pc210_universal,
> trats, smdkc100, smdkv310 config files.
>
> Signed-off-by: Rajeshwari Shinde <rajeshwari.s at samsung.com>
Acked-by: Simon Glass <sjg at chromium.org>
This looks right to me.
It would be useful to standardise the GPIO functions a little more -
so for example we could have a generic gpio_set_pull() which calls the
Samsung one, a little like the generic GPIO calls today. That API
would go in asm-generic/gpio.h. However I'm not sure how far we can
standardise this - pullup/pulldown probably, but I'm not sure about
driver strength and slew rate.
> ---
> Chnages in V3:
> - New Patch
> arch/arm/cpu/armv7/exynos/pinmux.c | 134 +++++++++++++++---------------
> arch/arm/include/asm/arch-exynos/gpio.h | 26 +++---
> arch/arm/include/asm/arch-s5pc1xx/gpio.h | 26 +++---
> board/samsung/goni/goni.c | 4 +-
> board/samsung/origen/origen.c | 8 +-
> board/samsung/smdk5250/smdk5250.c | 8 +-
> board/samsung/smdkc100/smdkc100.c | 2 +-
> board/samsung/smdkv310/smdkv310.c | 10 +-
> board/samsung/trats/trats.c | 16 ++--
> board/samsung/universal_c210/universal.c | 36 ++++----
> drivers/gpio/s5p_gpio.c | 20 ++--
> 11 files changed, 145 insertions(+), 145 deletions(-)
>
Regards,
Simon
More information about the U-Boot
mailing list