[U-Boot] [PATCH 1/1] socfpga: Consolidating reset code into reset_manager.c. Also separating reset configuration for virtual target and real hardware Cyclone V development kit
Pavel Machek
pavel at denx.de
Tue Jul 2 13:52:10 CEST 2013
Hi!
> > > > > @@ -21,6 +21,7 @@
> > > > > void reset_cpu(ulong addr);
> > > > > void reset_deassert_peripherals_handoff(void);
> > > > >
> > > > > +#if defined(CONFIG_SOCFPGA_VIRTUAL_TARGET)
> > > > > struct socfpga_reset_manager {
> > > > > u32 padding1;
> > > > > u32 ctrl;
> > > > > @@ -31,7 +32,23 @@ struct socfpga_reset_manager {
> > > > > u32 per2_mod_reset;
> > > > > u32 brg_mod_reset;
> > > > > };
> > > > > +#else
> > > > > +struct socfpga_reset_manager {
> > > > > + u32 status;
> > > > > + u32 ctrl;
> > > > > + u32 counts;
> > > > > + u32 padding1;
> > > > > + u32 mpu_mod_reset;
> > > > > + u32 per_mod_reset;
> > > > > + u32 per2_mod_reset;
> > > > > + u32 brg_mod_reset;
> > > > > +};
> > > > > +#endif
> > > > >
> > (You could add /* this is unimplemented on virtual platform */, or
> > maybe even per-field ifdef. It will still be more readable.)
>
> Oh.. I got your point now :)
> Its a good suggestion and let me do it for next revision.
Looks good now. Thanks!
Pavel
--
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html
More information about the U-Boot
mailing list