[U-Boot] [PATCH 2/6] drivers/power/pmic: Add tps65217 driver
Tom Rini
trini at ti.com
Thu Jul 25 20:05:44 CEST 2013
On Thu, Jul 25, 2013 at 12:21:41PM -0500, Dan Murphy wrote:
> On 07/25/2013 09:37 AM, Tom Rini wrote:
> > On Tue, Jul 23, 2013 at 01:34:15PM -0500, Dan Murphy wrote:
> >> On 07/19/2013 02:00 PM, Tom Rini wrote:
> >>> From: Greg Guyotte <gguyotte at ti.com>
> >>>
> >>> Add a driver for the TPS65217 PMIC that is found in the Beaglebone
> >>> family of boards.
>
> Can we add the public reference to the technical manual in the commit message?
>
> I found <http://www.ti.com/lit/ug/slvu580b/slvu580b.pdf>http://www.ti.com/lit/ds/symlink/tps65217b.pdf
I've got the stable link in the header file, now (also for tps65910).
[snip]
> >>> +{
> >>> + if ((dc_cntrl_reg != DEFDCDC1) && (dc_cntrl_reg != DEFDCDC2) &&
> >>> + (dc_cntrl_reg != DEFDCDC3))
> >> What do these magic numbers mean? Are these HEX numbers or a string?
> > OK, it took me a minute to understand your question here. These are
> > defines to register names, matching the TRM for the part. The register
> > names are however annoyingly and easily confused as hex values.
>
> Maybe we can rename the #defines so they are not so confusing. Maybe
> something like
>
> #define TPS65217_<register name> <register offset>
>
> So these will become
> #define TPS65217_DEFDCDC1 0xe
> #define TPS65217_DEFDCDC2 0xf
> #define TPS65217_DEFDCDC3 0x10
>
> This will at least keep other defines like CHIPID and SEQ unique as well.
I can do that, yeah.
--
Tom
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 836 bytes
Desc: Digital signature
URL: <http://lists.denx.de/pipermail/u-boot/attachments/20130725/52c1305e/attachment.pgp>
More information about the U-Boot
mailing list