[U-Boot] [PATCH V3 07/10] palmas: rename init_settings to an generic palmas init

Nishanth Menon nm at ti.com
Tue Mar 26 16:20:55 CET 2013


Since TPS659038/TWL6035/TWL6037 all belong to palmas family of TI PMICs,
rename twl6035_init_settings with an more generic palmas_init_settings

Signed-off-by: Nishanth Menon <nm at ti.com>
---
V3: new patch
 board/ti/omap5_evm/evm.c |    2 +-
 drivers/power/palmas.c   |    2 +-
 include/palmas.h         |    2 +-
 3 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/board/ti/omap5_evm/evm.c b/board/ti/omap5_evm/evm.c
index 701842b..46db1bf 100644
--- a/board/ti/omap5_evm/evm.c
+++ b/board/ti/omap5_evm/evm.c
@@ -64,7 +64,7 @@ int board_eth_init(bd_t *bis)
 int misc_init_r(void)
 {
 #ifdef CONFIG_PALMAS_POWER
-	twl6035_init_settings();
+	palmas_init_settings();
 #endif
 	return 0;
 }
diff --git a/drivers/power/palmas.c b/drivers/power/palmas.c
index 8ed7742..bf36a19 100644
--- a/drivers/power/palmas.c
+++ b/drivers/power/palmas.c
@@ -45,7 +45,7 @@ static inline int palmas_read_u8(u8 chip_no, u8 reg, u8 *val)
 	return i2c_read(chip_no, reg, 1, val, 1);
 }
 
-void twl6035_init_settings(void)
+void palmas_init_settings(void)
 {
 	return;
 }
diff --git a/include/palmas.h b/include/palmas.h
index cf836d7..6618aad 100644
--- a/include/palmas.h
+++ b/include/palmas.h
@@ -38,5 +38,5 @@
 
 int twl6035_i2c_write_u8(u8 chip_no, u8 val, u8 reg);
 int twl6035_i2c_read_u8(u8 chip_no, u8 *val, u8 reg);
-void twl6035_init_settings(void);
+void palmas_init_settings(void);
 int twl6035_mmc1_poweron_ldo(void);
-- 
1.7.9.5



More information about the U-Boot mailing list