[U-Boot] [PATCH V3 00/10] OMAP3-5: TWL[46]03[05]: cleanup register access and misc minimal cleanups

Sricharan R r.sricharan at ti.com
Wed Mar 27 05:17:40 CET 2013


Hi Nishanth,

On Tuesday 26 March 2013 08:50 PM, Nishanth Menon wrote:
> This series helps standardize register parameters for TWL4030, 6030 and 6035
> used in various OMAP3,4,5 based platforms.
> 
> For historical reasons, we have been following val, reg as the order of
> parameters while we have reg, val in every other i2c apis including i2c
> mw/mr command @ u-boot cmd line, with kernel APIs, i2cget, i2cset utilities.
> 
> Instead of maintaining this forked implementation, it is never too late to
> fix them.
> 
> Since TPS659038/TWL6035/TWL6037 all belong to the Palmas family of TI PMICs
> and are mostly compatible among each other, we rename twl6035 to palmas as part
> of this cleanup.
> 
> Build tested (MAKEALL) platforms-at least these seem to be be impacted ones:
> cm_t35
> devkit8000
> dig297
> igep0020
> igep0020_nand
> igep0030
> igep0030_nand
> nokia_rx51
> omap3_beagle
> omap3_evm
> omap3_evm_quick_mmc
> omap3_evm_quick_nand
> omap3_logic
> omap3_mvblx
> omap3_overo
> omap3_pandora
> omap3_sdp3430
> omap3_zoom1
> omap3_zoom2
> omap4_panda
> omap4_sdp4430
> omap5_evm
> tricorder
> dra7xx_evm
> 
> Boot tested platforms (upto kernel+shell with dtb):
> omap3_beagle - tested on beagle XM (C1), beagle(C1D) - TWL4030
> omap4_panda - tested on PandaBoard(A3) and PandaBoard-ES(EB3) - TWL6030
> omap5_evm - OMAP5 uEVM - TWL6035
> 
> twl4030 changes are little wider in scope, so I have split them
> into two patches to help review
> 
> Series is based on u-boot master:
>  master      8b906a9 Merge branch 'spi' of git://git.denx.de/u-boot-x86
> (rationale being the changes if done on v2013.04-rc1 have much changes to
>  allow this series to apply cleanly on the latest)
> 
> NOTE: the series tries to cleanup existing indentation style to allow the
> new code to be in sync with checkpatch suggestions.
> 
> V2: http://marc.info/?t=136398816800006&r=1&w=2
> V1: http://patchwork.ozlabs.org/patch/227112/
> 
> Changes since V2 in this series:
> 	- rename of twl6035 to palmas and associated changes
> 	- minor updates to cleaup checkpatch warnings 
> 
> Nishanth Menon (10):
>   twl4030: make twl4030_i2c_write_u8 prototype consistent
>   twl4030: make twl4030_i2c_read_u8 prototype consistent
>   twl6030: twl6030_i2c_[read|write]_u8 prototype consistent
>   twl6030: move twl6030 register access functions to common header file
>   twl6030: add header guard
>   twl6035: rename to palmas
>   palmas: rename init_settings to an generic palmas init
>   palmas: rename twl6035_mmc1_poweron_ldo with an palmas generic
>     function
>   palmas: use palmas_i2c_[read|write]_u8
>   palmas: add header guard
> 
>  board/cm_t35/cm_t35.c                 |   24 +++++------
>  board/nokia/rx51/rx51.c               |   52 +++++++++++------------
>  board/pandora/pandora.c               |    3 +-
>  board/ti/dra7xx/evm.c                 |    2 +-
>  board/ti/omap5_evm/evm.c              |    6 +--
>  drivers/misc/twl4030_led.c            |    4 +-
>  drivers/mmc/omap_hsmmc.c              |    8 ++--
>  drivers/power/Makefile                |    2 +-
>  drivers/power/{twl6035.c => palmas.c} |   34 +++------------
>  drivers/power/twl4030.c               |   16 +++----
>  drivers/power/twl6030.c               |   75 ++++++++++++++-------------------
>  drivers/usb/phy/twl4030.c             |   48 ++++++++++-----------
>  include/configs/omap5_evm.h           |    2 +-
>  include/{twl6035.h => palmas.h}       |   28 +++++++++---
>  include/twl4030.h                     |    4 +-
>  include/twl6030.h                     |   16 +++++++
>  16 files changed, 162 insertions(+), 162 deletions(-)
>  rename drivers/power/{twl6035.c => palmas.c} (61%)
>  rename include/{twl6035.h => palmas.h} (68%)
> 
> Regards,
> Nishanth Menon

 Acked-by: R Sricharan <r.sricharan at ti.com> for the series

Regards,
 Sricharan



More information about the U-Boot mailing list