[U-Boot] [U-Boot, v3, 5/5] mx6cuboxi: Load the correct 'fdt_file' variable
Fabio Estevam
festevam at gmail.com
Sat Apr 25 17:30:47 CEST 2015
Hi Stefano and Vagrant,
On Sat, Apr 25, 2015 at 3:05 AM, Stefano Babic <sbabic at denx.de> wrote:
> Are you sure ? I think Fabio's intention is to have setenv fdt_file as
> part of check_suffix, and it is not if you add a trailing \0
That's correct.
>
>> and maybe should
>> be indented to line up with the if statement:
>>
>> + "setenv fdt_file ${dts_prefix}${dts_suffix}\0" \
>
> If checkpatch does not complain...
checkpatch did not complain, but for better readability I could do as
Vagrant suggested and write it like:
#define CONFIG_EXTRA_ENV_SETTINGS \
"script=boot.scr\0" \
"image=zImage\0" \
- "fdt_file=" CONFIG_DEFAULT_FDT_FILE "\0" \
+ "check_suffix=" \
+ "if is_hummingboard; then " \
+ "setenv dts_suffix -hummingboard.dtb;" \
+ "else " \
+ "setenv dts_suffix -cubox-i.dtb;" \
+ "fi; "\
+ "setenv fdt_file ${dts_prefix}${dts_suffix};" \
I can send a v4 with such format.
Thanks,
Fabio Estevam
More information about the U-Boot
mailing list