[U-Boot] [PATCH v2 00/20] x86: Add CPU uclass and multi-core support for Minnowboard MAX

Simon Glass sjg at chromium.org
Wed Apr 29 16:45:57 CEST 2015


Hi Bin,

On 29 April 2015 at 08:42, Bin Meng <bmeng.cn at gmail.com> wrote:
> Hi Simon,
>
> On Wed, Apr 29, 2015 at 11:07 AM, Bin Meng <bmeng.cn at gmail.com> wrote:
>> Hi Simon,
>>
>> On Wed, Apr 29, 2015 at 10:25 AM, Simon Glass <sjg at chromium.org> wrote:
>>> This series adds a new CPU uclass which is intended to be useful on any
>>> architecture. So far it has a very simple interface and a command to show
>>> CPU details.
>>>
>>> This series also introduces multi-core init for x86. It is implemented and
>>> enabled on Minnowboard MAX, a single/dual-core Atom board. The CPU uclass is
>>> implemented for x86 and the Simple Firmware Interface provides these details
>>> to the kernel, since ACPI is not yet available.
>>>
>>> With these changes Minnowboard MAX can boot into Linux with both cores
>>> enabled.
>>>
>>> This series is available at u-boot-x86 branch 'cpu-working'.
>>>
>>> Changes in v2:
>>> - Use capitals for the header guard
>>> - Change 'print' to 'Print' in comment
>>> - Correct bugs in number output
>>> - Change header guard to capital letters
>>> - Change get_info() in function comment to cpu_get_info()
>>> - Rename CONFIG_SFI to CONFIG_GENERATE_SFI_TABLE and move within Kconfig
>>> - Correct Kconfig help indentation and text
>>> - Drop SFI_BASE config option
>>> - Always build sfi.o
>>> - Use SFI_TABLE_MAX_ENTRIES instead of 16 and ARRAY_SIZE()
>>> - Make get_entry_start() static
>>> - Use table_compute_checksum() to computer checksum
>>> - Add a few blank lines
>>> - Move patch to after the CPU uclass patch
>>> - Drop the RTC table as it is not needed
>>> - Move SFI calling code to write_tables()
>>> - Remove IDLE table
>>> - Remove SFI_SYST_SEARCH_BEGIN and SFI_SYST_SEARCH_END
>>> - Move '__packed' to immediately after 'struct'
>>> - Add SFI_DEV_TYPE_SD and convert to enum
>>> - Remove #ifdef CONFIG_SFI from hedaer file
>>> - Move sfi.h header file to arch/x86/include/asm
>>> - Remove unnecessary \t\n after mfence assembler instruction
>>>
>>
>> This is quick! :) I have not finished reviewing the v1. I will
>> continue reviewing the v2.
>>
>>> Simon Glass (20):
>>>   Fix comment nits in board_f.c
>>>   dm: core: Add a function to bind a driver for a device tree node
>
> I've finished the review of this patch series, except this dm core
> one. I think maybe someone else who is more familiar with the dm
> internals than me could have a look. Thanks for working on these
> patches. It's really great we can boot an SMP kernel.

Thanks very much for your thorough review. I'll likely pull in the
first part of the series and then tidy up and send the rest soon.

Yes it's good to get SMP. We still have a few more things needed.
Pinmux is in progress. ACPI should happen over the 4-5 months. We
probably need some sort of 'SMBIOS' interface, and perhaps SMM.

Regards,
Simon


More information about the U-Boot mailing list