[U-Boot] [PATCH v3 0/5] x86: Add CPU uclass and multi-core support for Minnowboard MAX

Bin Meng bmeng.cn at gmail.com
Thu Apr 30 08:16:14 CEST 2015


Hi Simon,

On Thu, Apr 30, 2015 at 1:11 PM, Simon Glass <sjg at chromium.org> wrote:
> Hi Bin,
>
> On 29 Apr 2015 10:26 pm, "Simon Glass" <sjg at chromium.org> wrote:
>>
>> This series adds a new CPU uclass which is intended to be useful on any
>> architecture. So far it has a very simple interface and a command to show
>> CPU details.
>>
>> This series also introduces multi-core init for x86. It is implemented and
>> enabled on Minnowboard MAX, a single/dual-core Atom board. The CPU uclass
>> is
>> implemented for x86 and the Simple Firmware Interface provides these
>> details
>> to the kernel, since ACPI is not yet available.
>>
>> With these changes Minnowboard MAX can boot into Linux with both cores
>> enabled.
>>
>> This series is available at u-boot-x86 branch 'cpu-working'.
>>
>> Changes in v3:
>> - Rename CONFIG_STACK_SIZE to CONFIG_AP_STACK_SIZE
>> - Remove sipi_vector_location and sipi_vector_location_size variables
>> - Remove annoying /* 1ms */ comments
>> - Rename sipi.S to sipi_vector.S
>> - Correct 'ap_start32' to 'ap_start'
>> - Use macros for cr0 bit fields
>> - Correct style in a multi-line comment
>> - Use UCODE_HEADER_LEN instead of 48
>> - Remove unnecessary underscores in MP_FR_BLOCK_APS and MP_FR_NOBLOCK_APS
>> - Use 'cpu number' instead of 'coreboot cpu number'
>> - Remove a stray blank line in sipi.h
>> - Enhance comment for @microcode_lock
>> - Rename SMM_DEFAULT_BASE/SIZE to AP_DEFAULT_BASE/SIZE and drop smm.h
>> - Use data32 instead of our own 'o32'
>> - Move NUM_FIXED_MTRRS to mtrr.h
>> - Avoid using asmlinkage on ap_init()
>> - Add msr_clrbits_64() too
>> - Collect all new MSRs into msr-index.h
>> - Spell 'BayTrail' like so
>> - Make set_max_freq() static
>
> I did not sort out the secondary CPU init in this series. I will take a
> look.
>

Thanks. What about the LAPIC patch? Is it dropped?
http://patchwork.ozlabs.org/patch/465854/

[snip]

Regards,
Bin


More information about the U-Boot mailing list