[U-Boot] [PATCH v8 00/14] sf: Tuning spi-flash layer
Jagan Teki
jteki at openedev.com
Sun Dec 6 19:34:12 CET 2015
This series bypasses MTD changes from previous series[1][2] and
entire series tunned spi-flash layer for better code handling.
Changes in v8:
- Rebase to master
- PATCH v8 12/14, 13/14, 14/14 added newly.
Changes in v7:
- Rebase to master
- Few patch bisectable separations
Changes in v6, v5, v4, v3, v2:
- One patch bisectable separation
- Rebase to master
Testing:
$ git clone git://git.denx.de/u-boot-spi.git
$ cd u-boot-spi
$ git checkout -b next origin/next
[1] http://permalink.gmane.org/gmane.comp.boot-loaders.u-boot/242397
[2] http://permalink.gmane.org/gmane.comp.boot-loaders.u-boot/233262
thanks!
Jagan.
Jagan Teki (14):
sf: spi_flash_validate_params => spi_flash_scan
sf: Move spi_flash_scan code to sf_ops
sf: Move read_id code to sf_ops
sf: probe: Code cleanup
sf: Use static for file-scope functions
sf: Fix Makefile
sf: Use simple name for register access functions
sf: Flash power up read-only based on idcode0
sf: Remove unneeded header includes
sf: Remove unneeded SST_BP and SST_WP
sf: ops: Fix missing break on spansion read_bar
sf: sf_probe: Remove spi_slave pointer argument
sf: Use static for file-scope functions
sf: Rename sf_ops.c to spi-flash.c
drivers/mtd/spi/Makefile | 6 +-
drivers/mtd/spi/sf_internal.h | 38 ++-
drivers/mtd/spi/sf_probe.c | 373 +--------------------------
drivers/mtd/spi/{sf_ops.c => spi-flash.c} | 406 ++++++++++++++++++++++++++++--
4 files changed, 408 insertions(+), 415 deletions(-)
rename drivers/mtd/spi/{sf_ops.c => spi-flash.c} (60%)
--
1.9.1
More information about the U-Boot
mailing list