[U-Boot] [PATCH v3 00/10] sf: Add flash_ids inside Core

Jagan Teki jteki at openedev.com
Thu Dec 31 10:21:55 CET 2015


This series handle flash_ids stuff inside spi_flash core.

Changes for v3:
	- Updated SNOR_F_SST_WRITE at sf_probe.c	
	- two patches, wrt sanbox newly added

Changes for v2:
        - Remove SECT_4K flag for s25fl128s

Jagan Teki (10):
  sf: Add spi_flash_ids local to core
  sf: Rename SST_WR to SST_WRITE
  sf: Remove SPI_NOR_DUAL|QUAD_READ
  sf: Use sf_params in sandbox
  sf: Remove SECT_32K
  sf: Add SECT_4K_PMC
  sf: Use CONFIG_SPI_FLASH_USE_4K_SECTORS
  sf: Fix few naming convention for read modes
  sf: sandbox: Move spi_flash_params_table
  sf: Drop sf_params.c

 drivers/mtd/spi/Makefile      |   2 +-
 drivers/mtd/spi/sandbox.c     | 155 +++++++++++++++
 drivers/mtd/spi/sf_internal.h |  29 +--
 drivers/mtd/spi/sf_params.c   | 146 --------------
 drivers/mtd/spi/sf_probe.c    |   2 +-
 drivers/mtd/spi/spi_flash.c   | 446 +++++++++++++++++++++++++++++++++++-------
 include/linux/err.h           |   5 +
 7 files changed, 538 insertions(+), 247 deletions(-)
 delete mode 100644 drivers/mtd/spi/sf_params.c

-- 
1.9.1



More information about the U-Boot mailing list