[U-Boot] [PATCH v2 0/4] musb device model support series

Hans de Goede hdegoede at redhat.com
Sun Jul 5 12:09:55 CEST 2015


Hi,

On 01-07-15 21:47, Simon Glass wrote:
> Hi Hans,
>
> On 1 July 2015 at 12:52, Hans de Goede <hdegoede at redhat.com> wrote:
>>
>> Hi Simon, Marek,
>>
>> Here is a series with just the patches which needed work after my v1
>> posting of this series.
>>
>> I've a rebased version of the entire series (some patches needed adjustment
>> after the recent Kconfig / defconfig changes) in my personal tree.
>>
>> Simon, AFAIK the plan is still for this to go upstream through your tree,
>> let me know when you're ready to take this series, and on which branch you
>> want it based, and I'll create a branch for you to pull.
>
> Do you mean I should apply the entire series, or just the first 15 patches?

My initial intention was for you to take the entire series, but given
the recent Kconfig changes and conflicts in the sunxi bits I think it
is best if you just take the dm/usb and musb device-model conversion
patches. Then I'll merge the sunxi bits after u-boot-dm/next has
been merged.

> I've set up a u-boot-dm/next. I'm planning to do that again to speed
> up merging when the window opens.
>
> But I'd prefer to take patches from patchwork - can I just do that?

Yes that should work. Note that my v2 series introduces a few new patches
as a result of your review of v1, so the entire series I would like you
to merge is (in order they should be merged):

usb: Drop device-model specific copy of usb_legacy_port_reset
usb: usb_setup_device: Drop unneeded portnr function argument
usb: Pass device instead of portnr to usb_legacy_port_reset
usb: Add an usb_device parameter to usb_reset_root_port
dm: Export device_remove_children / device_unbind_children (v2)
dm: usb: Fix "usb tree" output
dm: usb: Document that mixing DM_DEVICE_REMOVE and DM_USB is a bad idea (v2)
dm: usb: Use device_unbind_children to clean up usb devs on stop (v2)
dm: usb: Rename usb_find_child to usb_find_emul_child (v2)
dm: usb: Allow usb host drivers to implement usb_reset_root_port
dm: usb: Do not assume that first child is always a hub
musb: Allow musb_platform_enable to return an error code
musb: Update usb-compat to work with struct usb_device without a parent ptr
musb: Rename and wrap public functions
musb: Add musb_host_data struct to hold global data
musb: Add device-model support to the musb-host u-boot glue

I think you should be able to pick these from patchwork without
issues. Let me know if you hit any problems, then I will post a v3
of the entire series re-based on top of u-boot-dm/next.

Regards,

Hans


More information about the U-Boot mailing list