[U-Boot] [PATCH 07/11] x86: pci: Tidy up the generic x86 PCI driver
Bin Meng
bmeng.cn at gmail.com
Mon Jun 8 04:15:24 CEST 2015
Hi Simon,
On Sun, Jun 7, 2015 at 10:50 PM, Simon Glass <sjg at chromium.org> wrote:
> This driver should use the x86 PCI configuration functions. Also adjust its
> compatible string to something generic (i.e. without a vendor name).
>
> Signed-off-by: Simon Glass <sjg at chromium.org>
> ---
>
> drivers/pci/pci_x86.c | 5 ++++-
> 1 file changed, 4 insertions(+), 1 deletion(-)
>
> diff --git a/drivers/pci/pci_x86.c b/drivers/pci/pci_x86.c
> index 901bdca..9f842c3 100644
> --- a/drivers/pci/pci_x86.c
> +++ b/drivers/pci/pci_x86.c
> @@ -7,12 +7,15 @@
> #include <common.h>
> #include <dm.h>
> #include <pci.h>
> +#include <asm/pci.h>
>
> static const struct dm_pci_ops x86_pci_ops = {
To keep the consistent naming to match the driver name, can we rename
this to pci_x86_ops?
> + .read_config = pci_x86_read_config,
> + .write_config = pci_x86_write_config,
Can we move pci_x86_read_config() and pci_x86_write_config() from
arch/x86/cpu/pci.c to this file to make it a complete driver file?
Also create a new header file pci_x86.h to declare these two so that
it can be used by ivybridge.
> };
>
> static const struct udevice_id x86_pci_ids[] = {
Can we rename this to pci_x86_ids?
> - { .compatible = "x86,pci" },
> + { .compatible = "pci-x86" },
> { }
> };
>
> --
Regards,
Bin
More information about the U-Boot
mailing list