[U-Boot] [PATCH v3 16/54] dm: core: Correct device_get_child_by_of_offset() parameter
Simon Glass
sjg at chromium.org
Tue Jun 23 23:38:38 CEST 2015
This parameter is named 'seq' but should be named 'of_offset'.
Signed-off-by: Simon Glass <sjg at chromium.org>
---
Changes in v3: None
Changes in v2: None
drivers/core/device.c | 4 ++--
include/dm/device.h | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/core/device.c b/drivers/core/device.c
index 43aff54..456426a 100644
--- a/drivers/core/device.c
+++ b/drivers/core/device.c
@@ -459,14 +459,14 @@ int device_find_child_by_of_offset(struct udevice *parent, int of_offset,
return -ENODEV;
}
-int device_get_child_by_of_offset(struct udevice *parent, int seq,
+int device_get_child_by_of_offset(struct udevice *parent, int node,
struct udevice **devp)
{
struct udevice *dev;
int ret;
*devp = NULL;
- ret = device_find_child_by_of_offset(parent, seq, &dev);
+ ret = device_find_child_by_of_offset(parent, node, &dev);
return device_get_device_tail(dev, ret, devp);
}
diff --git a/include/dm/device.h b/include/dm/device.h
index 9a94ee1..9fa0048 100644
--- a/include/dm/device.h
+++ b/include/dm/device.h
@@ -386,7 +386,7 @@ int device_find_child_by_of_offset(struct udevice *parent, int of_offset,
* @devp: Returns pointer to device if found, otherwise this is set to NULL
* @return 0 if OK, -ve on error
*/
-int device_get_child_by_of_offset(struct udevice *parent, int seq,
+int device_get_child_by_of_offset(struct udevice *parent, int of_offset,
struct udevice **devp);
/**
--
2.4.3.573.g4eafbef
More information about the U-Boot
mailing list