[U-Boot] [PATCH 3/4] common/lcd_console: move single static variables into common (static) structure
Nikita Kiryanov
nikita at compulab.co.il
Sun Mar 15 19:57:08 CET 2015
Hi Hannes,
On 03/11/2015 02:57 PM, Hannes Petermaier wrote:
> From: Hannes Petermaier <hannes.petermaier at br-automation.com>
>
> For coming implementation of lcd_console rotation, we will need some more
> variables for holding information about framebuffer size, rotation, ...
>
> For better readability we catch all them into a common structure.
>
> Signed-off-by: Hannes Petermaier <hannes.petermaier at br-automation.com>
> Signed-off-by: Hannes Petermaier <oe5hpm at oevsv.at>
> ---
>
> common/lcd_console.c | 76 +++++++++++++++++++++++++-------------------------
> 1 file changed, 38 insertions(+), 38 deletions(-)
>
> diff --git a/common/lcd_console.c b/common/lcd_console.c
> index b7dda7a..cac77be 100644
> --- a/common/lcd_console.c
> +++ b/common/lcd_console.c
> @@ -11,48 +11,49 @@
> #include <video_font.h> /* Get font data, width and height */
>
> #define CONSOLE_ROW_SIZE (VIDEO_FONT_HEIGHT * lcd_line_length)
> -#define CONSOLE_ROW_FIRST lcd_console_address
> -#define CONSOLE_SIZE (CONSOLE_ROW_SIZE * console_rows)
> +#define CONSOLE_ROW_FIRST cons.lcd_address
> +#define CONSOLE_SIZE (CONSOLE_ROW_SIZE * cons.rows)
>
> -static short console_curr_col;
> -static short console_curr_row;
> -static short console_cols;
> -static short console_rows;
> -static void *lcd_console_address;
> +struct console_t {
> + short curr_col, curr_row;
> + short cols, rows;
> + void *lcd_address;
Can this be void *base_address? I think that's a bit more descriptive.
Other than that,
Acked-by: Nikita Kiryanov <nikita at compulab.co.il>
> +};
--
Regards,
Nikita Kiryanov
More information about the U-Boot
mailing list