[U-Boot] [PATCH 00/14] dm: pci: Support native driver model calls

Simon Glass sjg at chromium.org
Thu Nov 12 22:45:21 CET 2015


At present driver model supports PCI, but most of the code in U-Boot still
uses the old API.

This series changes the 'pci' command so that the new API is used. The old
API is placed behind a 'compatibility' option. The overall goal is to
deprecate the old API and remove all use of it. The auto-config and device
finding will be the subject of future patches.


Simon Glass (14):
  pci: Move 'pci scan' code in with other commands
  pci: Use a common return in command processing
  pci: Use a separate variable for the bus number
  pci: Refactor the pciinfo() function
  dm: pci: Add a comment about how to find struct pci_controller
  dm: pci: Rename pci_auto.c to pci_auto_old.c
  dm: pci: Move common auto-config functions to a common file
  dm: pci: Reorder functions in cmd_pci.c
  pci: Use common functions to read/write config
  pci: Fix pci_field_width() for 32-bit values
  pci: Use a separate 'dev' variable for the PCI device
  pci: Move PCI header output code into its own function
  dm: pci: Convert 'pci' command to driver model
  dm: pci: Disable PCI compatibility functions by default

 arch/arm/mach-tegra/Kconfig                |   2 +
 arch/x86/Kconfig                           |   3 +
 common/cmd_pci.c                           | 579 +++++++++++++++++++----------
 configs/sandbox_defconfig                  |  10 +-
 drivers/pci/Kconfig                        |   9 +
 drivers/pci/Makefile                       |   5 +-
 drivers/pci/pci_auto_common.c              | 128 +++++++
 drivers/pci/{pci_auto.c => pci_auto_old.c} | 122 ------
 include/common.h                           |   1 -
 include/pci.h                              |  23 +-
 10 files changed, 542 insertions(+), 340 deletions(-)
 create mode 100644 drivers/pci/pci_auto_common.c
 rename drivers/pci/{pci_auto.c => pci_auto_old.c} (79%)

-- 
2.6.0.rc2.230.g3dd15c0



More information about the U-Boot mailing list