[U-Boot] [PATCH 06/14] dm: pci: Rename pci_auto.c to pci_auto_old.c
Simon Glass
sjg at chromium.org
Thu Nov 12 22:45:27 CET 2015
This file should not be used with driver model as it has lots of legacy/
compatibility functions. Rename it to make this clear.
Signed-off-by: Simon Glass <sjg at chromium.org>
---
drivers/pci/Makefile | 2 +-
drivers/pci/{pci_auto.c => pci_auto_old.c} | 0
2 files changed, 1 insertion(+), 1 deletion(-)
rename drivers/pci/{pci_auto.c => pci_auto_old.c} (100%)
diff --git a/drivers/pci/Makefile b/drivers/pci/Makefile
index bcf8127..dee844f 100644
--- a/drivers/pci/Makefile
+++ b/drivers/pci/Makefile
@@ -13,7 +13,7 @@ obj-$(CONFIG_X86) += pci_x86.o
else
obj-$(CONFIG_PCI) += pci.o
endif
-obj-$(CONFIG_PCI) += pci_common.o pci_auto.o pci_rom.o
+obj-$(CONFIG_PCI) += pci_common.o pci_auto_old.o pci_rom.o
obj-$(CONFIG_FSL_PCI_INIT) += fsl_pci_init.o
obj-$(CONFIG_PCI_INDIRECT_BRIDGE) += pci_indirect.o
diff --git a/drivers/pci/pci_auto.c b/drivers/pci/pci_auto_old.c
similarity index 100%
rename from drivers/pci/pci_auto.c
rename to drivers/pci/pci_auto_old.c
--
2.6.0.rc2.230.g3dd15c0
More information about the U-Boot
mailing list