[U-Boot] [PATCH v7 33/34] sf: dataflash: Rename sf_dataflash.c to mtd_dataflash.c

Jagan Teki jteki at openedev.com
Thu Nov 26 13:04:17 CET 2015


Since dataflash driver is using mtd_info core functionalities
this patch renames file and config name similar way as Linux.

Cc: Haikun Wang <haikun.wang at freescale.com>
Signed-off-by: Jagan Teki <jteki at openedev.com>
---
 drivers/mtd/spi/Kconfig                             | 2 +-
 drivers/mtd/spi/Makefile                            | 2 +-
 drivers/mtd/spi/{sf_dataflash.c => mtd_dataflash.c} | 0
 include/configs/ls1021aqds.h                        | 2 +-
 4 files changed, 3 insertions(+), 3 deletions(-)
 rename drivers/mtd/spi/{sf_dataflash.c => mtd_dataflash.c} (100%)

diff --git a/drivers/mtd/spi/Kconfig b/drivers/mtd/spi/Kconfig
index 78932a4..6e9cc07 100644
--- a/drivers/mtd/spi/Kconfig
+++ b/drivers/mtd/spi/Kconfig
@@ -101,7 +101,7 @@ config SPI_FLASH_USE_4K_SECTORS
 	  Please note that some tools/drivers/filesystems may not work with
 	  4096 B erase size (e.g. UBIFS requires 15 KiB as a minimum).
 
-config SPI_FLASH_DATAFLASH
+config MTD_DATAFLASH
 	bool "AT45xxx DataFlash support"
 	depends on SPI_FLASH && DM_SPI_FLASH
 	help
diff --git a/drivers/mtd/spi/Makefile b/drivers/mtd/spi/Makefile
index 5eb4417..780e75f 100644
--- a/drivers/mtd/spi/Makefile
+++ b/drivers/mtd/spi/Makefile
@@ -13,5 +13,5 @@ obj-$(CONFIG_SPL_SPI_BOOT)	+= fsl_espi_spl.o
 endif
 
 obj-$(CONFIG_SPI_FLASH) += sf_probe.o sf_ops.o sf_params.o sf.o
-obj-$(CONFIG_SPI_FLASH_DATAFLASH) += sf_dataflash.o
+obj-$(CONFIG_MTD_DATAFLASH) += mtd_dataflash.o
 obj-$(CONFIG_SPI_FLASH_SANDBOX) += sandbox.o
diff --git a/drivers/mtd/spi/sf_dataflash.c b/drivers/mtd/spi/mtd_dataflash.c
similarity index 100%
rename from drivers/mtd/spi/sf_dataflash.c
rename to drivers/mtd/spi/mtd_dataflash.c
diff --git a/include/configs/ls1021aqds.h b/include/configs/ls1021aqds.h
index 00640cd..2ce6eb5 100644
--- a/include/configs/ls1021aqds.h
+++ b/include/configs/ls1021aqds.h
@@ -423,7 +423,7 @@ unsigned long get_board_ddr_clk(void);
 #if defined(CONFIG_FSL_DSPI) || defined(CONFIG_FSL_QSPI)
 #define CONFIG_CMD_SF
 #define CONFIG_DM_SPI_FLASH
-#define CONFIG_SPI_FLASH_DATAFLASH
+#define CONFIG_MTD_DATAFLASH
 #endif
 #endif
 
-- 
1.9.1



More information about the U-Boot mailing list