[U-Boot] [PATCH v7 00/34] sf: MTD support

Jagan Teki jteki at openedev.com
Thu Nov 26 13:24:21 CET 2015


On 26 November 2015 at 17:33, Jagan Teki <jteki at openedev.com> wrote:
> This series is combination of mtd and sf tunning stuff in previous
> version patches.[1][2]
>
> This is whole patch series for add mtd support to spi-flash
> framework and related stuff.
>
> The idea is to introduce the spi-nor flash framework which
> similar to Linux with driver-model support.
>
> Detail changes:
> - drivers/mtd/spi/sf_probe.c: spi-flash to spi drivers interface(dm and non-dm)
> - drivers/mtd/spi/sf_ops.c: Core spi-flash functionalities.
> - spi_flash ops and dm_spi_ops are not needed as flash opertaion are
>   common for dm and non-dm via MTD
>
> Changes in v7:
> - Rebase to master
> - Added MTD core support to dataflash
> - Few patch bisectable separations
>
> Changes in v6, v5, v4, v3, v2:
> - One patch bisectable separation
> - Rebase to master
> - added newly mtd stuff patches.
>
> Testing:
> $ git clone git://git.denx.de/u-boot-spi.git
> $ cd u-boot-spi
> $ git checkout -b spi-nor-mtd origin/next-spi-nor-mtd
>
> [1] http://u-boot.10912.n7.nabble.com/PATCH-v6-00-23-sf-MTD-support-td233769.html
> [2] http://lists.denx.de/pipermail/u-boot/2015-October/229857.html
>
> thanks!
> Jagan.
>
> Jagan Teki (34):
>   sf: spi_flash_validate_params => spi_flash_scan
>   sf: Move spi_flash_scan code to sf_ops
>   sf: Move read_id code to sf_ops
>   sf: probe: Code cleanup
>   sf: Use static for file-scope functions
>   sf: Fix Makefile
>   sf: Use simple name for register access functions
>   sf: Use flash function pointers in dm_spi_flash_ops
>   sf: Flash power up read-only based on idcode0
>   sf: Use static for file-scope functions
>   sf: Remove unneeded header includes
>   sf: probe: Use spi_flash_scan in dm-spi-flash
>   sf: Re-factorize spi_flash_probe_tail code
>   dm-sf: Re-factorize spi_flash_std_probe code
>   zynq: Enable CONFIG_SPL_MTD_SUPPORT
>   sf: Add MTD support to spi_flash
>   sf: Use mtd_info ops instead of spi_flash ops
>   cmd_sf: Use mtd->size instead of flash->size
>   sf: Use mtd->erasesize instead of flash->erase_size
>   dm-sf: use mtd_ops, drop dm_spi_flash_ops
>   sf: Use MTD lock operations
>   sf: Add MTD support for non-dm spi_flash interface
>   sf: probe: Minor cleanup
>   sf: Drop SNOR_F_SST_WR flash->flags
>   sf: Remove unneeded SST_BP and SST_WP
>   sf: ops: Fix missing break on spansion read_bar
>   sf: Drop SPI_FLASH_MTD driver
>   configs: Remove CONFIG_SPI_FLASH_MTD
>   sf: dataflash: Remove unneeded spi data
>   sf: dataflash: Move flash id detection into jedec_probe
>   sf: dataflash: Fix add_dataflash return logic
>   sf: dataflash: Add MTD core support
>   sf: dataflash: Rename sf_dataflash.c to mtd_dataflash.c
>   mtd: dataflash: Minor cleanups

Tested whole series except 'sf prot' and dataflash.

Tested-by: Jagan Teki <jteki at openedev.com>

thanks!
-- 
Jagan | openedev.


More information about the U-Boot mailing list