[U-Boot] [PATCH v3 00/13] dm: pci: Support native driver model calls
Simon Glass
sjg at chromium.org
Fri Nov 27 03:51:17 CET 2015
At present driver model supports PCI, but most of the code in U-Boot still
uses the old API.
This series changes the 'pci' command so that the new API is used. The old
API is placed behind a 'compatibility' option. The overall goal is to
deprecate the old API and remove all use of it. The auto-config and device
finding will be the subject of future patches.
Changes in v3:
- Use 'Show' instead of 'Shows' in the the pci_header_show() function comment
- Fix mix-up between PCI_SIZE_xx and byte size
- Fix 'switch (cmd)' merge error
Changes in v2:
- Squash in the patch to fix pci_field_width() for 32-bit values
- Rename '_byte' to class in pci_header_show()
- Fix 'autoconfiguration' typo
- Fix merge error in pciauto_setup_device() which removed needed code
- Add a new patch to update the function comments
- Add back the leading 0 in the printf() statements
- Refactor the patch based on dropping the earlier refactor patch
- Make pciinfo() static
- Drop patch: pci: Move 'pci scan' code in with other commands
- Move dm_pciauto_config_device() out of CONFIG_DM_PCI_COMPAT
Simon Glass (13):
pci: Use a common return in command processing
pci: Use a separate variable for the bus number
pci: Refactor the pciinfo() function
dm: pci: Add a comment about how to find struct pci_controller
dm: pci: Rename pci_auto.c to pci_auto_old.c
dm: pci: Move common auto-config functions to a common file
dm: pci: Reorder functions in cmd_pci.c
pci: Tidy up function comments in cmd_pci.c
pci: Use common functions to read/write config
pci: Use a separate 'dev' variable for the PCI device
pci: Move PCI header output code into its own function
dm: pci: Convert 'pci' command to driver model
dm: pci: Disable PCI compatibility functions by default
arch/arm/mach-tegra/Kconfig | 1 +
arch/x86/Kconfig | 3 +
common/cmd_pci.c | 631 ++++++++++++++++++-----------
configs/sandbox_defconfig | 1 +
drivers/pci/Kconfig | 9 +
drivers/pci/Makefile | 5 +-
drivers/pci/pci_auto_common.c | 128 ++++++
drivers/pci/{pci_auto.c => pci_auto_old.c} | 116 ------
include/common.h | 1 -
include/pci.h | 32 +-
10 files changed, 576 insertions(+), 351 deletions(-)
create mode 100644 drivers/pci/pci_auto_common.c
rename drivers/pci/{pci_auto.c => pci_auto_old.c} (81%)
--
2.6.0.rc2.230.g3dd15c0
More information about the U-Boot
mailing list