[U-Boot] [PATCH v2 14/26] dm: pci: Drop the old version of pci_find_device/s()

Simon Glass sjg at chromium.org
Sun Nov 29 21:17:59 CET 2015


Move these functions into the compatibility file so that they are not
available by default.

Signed-off-by: Simon Glass <sjg at chromium.org>
---

Changes in v2:
- Move the functions into pci_common.c so they can be used by old code
- Reword the commit message for clarity

 drivers/pci/pci_common.c | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/drivers/pci/pci_common.c b/drivers/pci/pci_common.c
index 2a14902..a4573b0 100644
--- a/drivers/pci/pci_common.c
+++ b/drivers/pci/pci_common.c
@@ -313,6 +313,7 @@ pci_addr_t pci_hose_phys_to_bus(struct pci_controller *hose,
 	return bus_addr;
 }
 
+#if !defined(CONFIG_DM_PCI) || defined(CONFIG_DM_PCI_COMPAT)
 pci_dev_t pci_find_device(unsigned int vendor, unsigned int device, int index)
 {
 	struct pci_device_id ids[2] = { {}, {0, 0} };
@@ -363,3 +364,4 @@ pci_dev_t pci_hose_find_devices(struct pci_controller *hose, int busnum,
 
 	return -1;
 }
+#endif /* !CONFIG_DM_PCI || CONFIG_DM_PCI_COMPAT */
-- 
2.6.0.rc2.230.g3dd15c0



More information about the U-Boot mailing list