[U-Boot] [PATCH v3 12/13] x86: qemu: rename qemu/acpi_table.c
Miao Yan
yanmiaobest at gmail.com
Mon May 23 04:37:21 CEST 2016
Rename qemu/acpi_table.c to qemu/e820.c, because ACPI stuff is moved
to qfw core, this file only contains code for installing e820 table.
Signed-off-by: Miao Yan <yanmiaobest at gmail.com>
Reviewed-by: Bin Meng <bmeng.cn at gmail.com>
---
Changes in v3:
- none
arch/x86/cpu/qemu/Makefile | 3 +--
arch/x86/cpu/qemu/{acpi_table.c => e820.c} | 0
2 files changed, 1 insertion(+), 2 deletions(-)
rename arch/x86/cpu/qemu/{acpi_table.c => e820.c} (100%)
diff --git a/arch/x86/cpu/qemu/Makefile b/arch/x86/cpu/qemu/Makefile
index 7c08c3d..a080c5e 100644
--- a/arch/x86/cpu/qemu/Makefile
+++ b/arch/x86/cpu/qemu/Makefile
@@ -8,5 +8,4 @@ ifndef CONFIG_EFI_STUB
obj-y += car.o dram.o
endif
obj-y += qemu.o
-obj-$(CONFIG_QFW) += cpu.o
-obj-$(CONFIG_GENERATE_ACPI_TABLE) += acpi_table.o
+obj-$(CONFIG_QFW) += cpu.o e820.o
diff --git a/arch/x86/cpu/qemu/acpi_table.c b/arch/x86/cpu/qemu/e820.c
similarity index 100%
rename from arch/x86/cpu/qemu/acpi_table.c
rename to arch/x86/cpu/qemu/e820.c
--
1.9.1
More information about the U-Boot
mailing list