[U-Boot] [PATCH 3/8] dm: blk: Add a function to find the next block device number

Andy Shevchenko andy.shevchenko at gmail.com
Mon Apr 24 08:04:43 UTC 2017


On Mon, Apr 24, 2017 at 5:02 AM, Simon Glass <sjg at chromium.org> wrote:
> At present this code is inline. Move it into a function to allow it to
> be used elsewhere.
>
> Signed-off-by: Simon Glass <sjg at chromium.org>

> +static int blk_next_free_devnum(enum if_type if_type)
> +{
> +       int ret;
> +
> +       ret = blk_find_max_devnum(if_type);
> +       if (ret == -ENODEV)
> +               return 0;

> +       else if (ret < 0)

Useless 'else'.

> +               return ret;
> +       else

Ditto.

> +               return ret + 1;
> +}

-- 
With Best Regards,
Andy Shevchenko


More information about the U-Boot mailing list