[U-Boot] [PATCH 7/7] mmc: atmel: rename CONFIG_ATMEL_SDHCI to CONFIG_MMC_SDHCI_ATMEL
Jaehoon Chung
jh80.chung at samsung.com
Tue Jan 31 13:54:30 CET 2017
On 01/30/2017 07:46 PM, Masahiro Yamada wrote:
> Make the naming scheme consistent; all SDHCI-base drivers prefixed
> with CONFIG_MMC_SDHCI_.
>
> While we are here, add "depends on ARCH_AT91".
>
> Signed-off-by: Masahiro Yamada <yamada.masahiro at socionext.com>
Applied on u-boot-mmc. Thanks!
Best Regards,
Jaehoon Chung
> ---
>
> Changes in v2: None
>
> configs/sama5d2_xplained_mmc_defconfig | 2 +-
> configs/sama5d2_xplained_spiflash_defconfig | 2 +-
> drivers/mmc/Kconfig | 23 ++++++++++++-----------
> drivers/mmc/Makefile | 2 +-
> 4 files changed, 15 insertions(+), 14 deletions(-)
>
> diff --git a/configs/sama5d2_xplained_mmc_defconfig b/configs/sama5d2_xplained_mmc_defconfig
> index a6daef4..000acee 100644
> --- a/configs/sama5d2_xplained_mmc_defconfig
> +++ b/configs/sama5d2_xplained_mmc_defconfig
> @@ -43,7 +43,7 @@ CONFIG_ATMEL_PIO4=y
> CONFIG_DM_I2C=y
> CONFIG_SYS_I2C_AT91=y
> CONFIG_DM_MMC=y
> -CONFIG_ATMEL_SDHCI=y
> +CONFIG_MMC_SDHCI_ATMEL=y
> CONFIG_MMC_SDHCI=y
> CONFIG_DM_SPI_FLASH=y
> CONFIG_SPI_FLASH=y
> diff --git a/configs/sama5d2_xplained_spiflash_defconfig b/configs/sama5d2_xplained_spiflash_defconfig
> index 41ab772..0838e41 100644
> --- a/configs/sama5d2_xplained_spiflash_defconfig
> +++ b/configs/sama5d2_xplained_spiflash_defconfig
> @@ -42,7 +42,7 @@ CONFIG_ATMEL_PIO4=y
> CONFIG_DM_I2C=y
> CONFIG_SYS_I2C_AT91=y
> CONFIG_DM_MMC=y
> -CONFIG_ATMEL_SDHCI=y
> +CONFIG_MMC_SDHCI_ATMEL=y
> CONFIG_MMC_SDHCI=y
> CONFIG_DM_SPI_FLASH=y
> CONFIG_SPI_FLASH=y
> diff --git a/drivers/mmc/Kconfig b/drivers/mmc/Kconfig
> index 520e7ea..0c07781 100644
> --- a/drivers/mmc/Kconfig
> +++ b/drivers/mmc/Kconfig
> @@ -51,17 +51,6 @@ config SPL_MMC_TINY
> operations too, which can remove the need for malloc support in SPL
> and thus further reduce footprint.
>
> -config ATMEL_SDHCI
> - bool "Atmel SDHCI controller support"
> - depends on DM_MMC && BLK && DM_MMC_OPS && ARCH_AT91
> - depends on MMC_SDHCI
> - help
> - This enables support for the Atmel SDHCI controller, which supports
> - the embedded MultiMedia Card (e.MMC) Specification V4.51, the SD
> - Memory Card Specification V3.0, and the SDIO V3.0 specification.
> - It is compliant with the SD Host Controller Standard V3.0
> - specification.
> -
> config MMC_DAVINCI
> bool "TI DAVINCI Multimedia Card Interface support"
> depends on ARCH_DAVINCI
> @@ -191,6 +180,18 @@ config MMC_SDHCI_SDMA
> This enables support for the SDMA (Single Operation DMA) defined
> in the SD Host Controller Standard Specification Version 1.00 .
>
> +config MMC_SDHCI_ATMEL
> + bool "Atmel SDHCI controller support"
> + depends on ARCH_AT91
> + depends on DM_MMC && BLK && DM_MMC_OPS && ARCH_AT91
> + depends on MMC_SDHCI
> + help
> + This enables support for the Atmel SDHCI controller, which supports
> + the embedded MultiMedia Card (e.MMC) Specification V4.51, the SD
> + Memory Card Specification V3.0, and the SDIO V3.0 specification.
> + It is compliant with the SD Host Controller Standard V3.0
> + specification.
> +
> config MMC_SDHCI_BCM2835
> tristate "SDHCI support for the BCM2835 SD/MMC Controller"
> depends on ARCH_BCM283X
> diff --git a/drivers/mmc/Makefile b/drivers/mmc/Makefile
> index e63f439..e78bd0d 100644
> --- a/drivers/mmc/Makefile
> +++ b/drivers/mmc/Makefile
> @@ -14,7 +14,6 @@ obj-$(CONFIG_GENERIC_MMC) += mmc_legacy.o
> endif
>
> obj-$(CONFIG_ARM_PL180_MMCI) += arm_pl180_mmci.o
> -obj-$(CONFIG_ATMEL_SDHCI) += atmel_sdhci.o
> obj-$(CONFIG_BFIN_SDH) += bfin_sdh.o
> obj-$(CONFIG_MMC_DAVINCI) += davinci_mmc.o
>
> @@ -53,6 +52,7 @@ endif
>
> # SDHCI
> obj-$(CONFIG_MMC_SDHCI) += sdhci.o
> +obj-$(CONFIG_MMC_SDHCI_ATMEL) += atmel_sdhci.o
> obj-$(CONFIG_MMC_SDHCI_BCM2835) += bcm2835_sdhci.o
> obj-$(CONFIG_MMC_SDHCI_CADENCE) += sdhci-cadence.o
> obj-$(CONFIG_MMC_SDHCI_KONA) += kona_sdhci.o
>
More information about the U-Boot
mailing list