[U-Boot] [PATCH 2/7] mmc: sandbox: rename CONFIG, fix dependency, and use it in Makefile

Jaehoon Chung jh80.chung at samsung.com
Tue Jan 31 13:53:17 CET 2017


On 01/30/2017 07:46 PM, Masahiro Yamada wrote:
> [1] Rename CONFIG_SANDBOX_MMC to CONFIG_MMC_SANDBOX for consistency
>     I want all MMC driver options prefixed with CONFIG_MMC_.
> 
> [2] Fix dependency
>     Add necessary depends on to avoid compile error.
>     Instead "depends on MMC" is unneeded because this config entry
>     resides inside of "if MMC".
> 
> [3] Currently, this config symbol is not referenced at all.
>     Use it to enable/disable the driver in Makefile.
> 
> Signed-off-by: Masahiro Yamada <yamada.masahiro at socionext.com>

Applied on u-boot-mmc. Thanks!

Best Regards,
Jaehoon Chung

> ---
> 
> Changes in v2: None
> 
>  configs/sandbox_defconfig     | 2 +-
>  configs/sandbox_spl_defconfig | 2 +-
>  drivers/mmc/Kconfig           | 5 +++--
>  drivers/mmc/Makefile          | 6 +-----
>  4 files changed, 6 insertions(+), 9 deletions(-)
> 
> diff --git a/configs/sandbox_defconfig b/configs/sandbox_defconfig
> index 877aa94..01f6f5d 100644
> --- a/configs/sandbox_defconfig
> +++ b/configs/sandbox_defconfig
> @@ -94,7 +94,7 @@ CONFIG_CROS_EC_SPI=y
>  CONFIG_PWRSEQ=y
>  CONFIG_SPL_PWRSEQ=y
>  CONFIG_I2C_EEPROM=y
> -CONFIG_SANDBOX_MMC=y
> +CONFIG_MMC_SANDBOX=y
>  CONFIG_SPI_FLASH_SANDBOX=y
>  CONFIG_SPI_FLASH=y
>  CONFIG_SPI_FLASH_ATMEL=y
> diff --git a/configs/sandbox_spl_defconfig b/configs/sandbox_spl_defconfig
> index 0569647..896b15d 100644
> --- a/configs/sandbox_spl_defconfig
> +++ b/configs/sandbox_spl_defconfig
> @@ -104,7 +104,7 @@ CONFIG_CROS_EC_SANDBOX=y
>  CONFIG_CROS_EC_SPI=y
>  CONFIG_PWRSEQ=y
>  CONFIG_SPL_PWRSEQ=y
> -CONFIG_SANDBOX_MMC=y
> +CONFIG_MMC_SANDBOX=y
>  CONFIG_SPI_FLASH_SANDBOX=y
>  CONFIG_SPI_FLASH=y
>  CONFIG_SPI_FLASH_ATMEL=y
> diff --git a/drivers/mmc/Kconfig b/drivers/mmc/Kconfig
> index df4913b..97d245e 100644
> --- a/drivers/mmc/Kconfig
> +++ b/drivers/mmc/Kconfig
> @@ -187,9 +187,10 @@ config MMC_UNIPHIER
>  	help
>  	  This selects support for the SD/MMC Host Controller on UniPhier SoCs.
>  
> -config SANDBOX_MMC
> +config MMC_SANDBOX
>  	bool "Sandbox MMC support"
> -	depends on MMC && SANDBOX
> +	depends on SANDBOX
> +	depends on BLK && DM_MMC_OPS && OF_CONTROL
>  	help
>  	  This select a dummy sandbox MMC driver. At present this does nothing
>  	  other than allow sandbox to be build with MMC support. This
> diff --git a/drivers/mmc/Makefile b/drivers/mmc/Makefile
> index 6af7f79..2747deb 100644
> --- a/drivers/mmc/Makefile
> +++ b/drivers/mmc/Makefile
> @@ -40,11 +40,7 @@ obj-$(CONFIG_X86) += pci_mmc.o
>  obj-$(CONFIG_PXA_MMC_GENERIC) += pxa_mmc_gen.o
>  obj-$(CONFIG_SUPPORT_EMMC_RPMB) += rpmb.o
>  obj-$(CONFIG_S3C_SDI) += s3c_sdi.o
> -ifdef CONFIG_BLK
> -ifdef CONFIG_GENERIC_MMC
> -obj-$(CONFIG_SANDBOX) += sandbox_mmc.o
> -endif
> -endif
> +obj-$(CONFIG_MMC_SANDBOX)		+= sandbox_mmc.o
>  obj-$(CONFIG_SH_MMCIF) += sh_mmcif.o
>  obj-$(CONFIG_SH_SDHI) += sh_sdhi.o
>  obj-$(CONFIG_ZYNQ_SDHCI) += zynq_sdhci.o
> 



More information about the U-Boot mailing list