[U-Boot] [PATCH 10/29] dm: scsi: Rename struct SCSI_cmd_block to struct scsi_cmd

Simon Glass sjg at chromium.org
Mon Jun 5 19:14:57 UTC 2017


This name should be lower case. Also the _block suffix is superfluous.
Rename it.

Signed-off-by: Simon Glass <sjg at chromium.org>
---

 drivers/usb/emul/sandbox_flash.c | 2 +-
 include/scsi.h                   | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/usb/emul/sandbox_flash.c b/drivers/usb/emul/sandbox_flash.c
index 73fa82b8e6..98d20c0bc1 100644
--- a/drivers/usb/emul/sandbox_flash.c
+++ b/drivers/usb/emul/sandbox_flash.c
@@ -244,7 +244,7 @@ static int handle_ufi_command(struct sandbox_flash_plat *plat,
 			      struct sandbox_flash_priv *priv, const void *buff,
 			      int len)
 {
-	const struct SCSI_cmd_block *req = buff;
+	const struct scsi_cmd *req = buff;
 
 	switch (*req->cmd) {
 	case SCSI_INQUIRY: {
diff --git a/include/scsi.h b/include/scsi.h
index f94b2ef514..5d6829d298 100644
--- a/include/scsi.h
+++ b/include/scsi.h
@@ -7,7 +7,7 @@
  #ifndef _SCSI_H
  #define _SCSI_H
 
-typedef struct SCSI_cmd_block{
+typedef struct scsi_cmd {
 	unsigned char		cmd[16];					/* command				   */
 	/* for request sense */
 	unsigned char		sense_buf[64]
-- 
2.13.0.506.g27d5fe0cd-goog



More information about the U-Boot mailing list