[U-Boot] [PATCH 05/17] board_f: powerpc: Rename get_clocks_866() to get_clocks()
Simon Glass
sjg at chromium.org
Tue Mar 28 16:27:20 UTC 2017
We really don't need to have a name like this in the generic init
sequence. Use the generic get_clocks() name so that we can merge these
two at some point.
Signed-off-by: Simon Glass <sjg at chromium.org>
---
arch/powerpc/cpu/mpc8xx/speed.c | 2 +-
common/board_f.c | 2 +-
include/common.h | 1 -
3 files changed, 2 insertions(+), 3 deletions(-)
diff --git a/arch/powerpc/cpu/mpc8xx/speed.c b/arch/powerpc/cpu/mpc8xx/speed.c
index 42442b8c98..613209cc6d 100644
--- a/arch/powerpc/cpu/mpc8xx/speed.c
+++ b/arch/powerpc/cpu/mpc8xx/speed.c
@@ -243,7 +243,7 @@ static long init_pll_866 (long clk);
* contains invalid value).
* This functions requires an MPC866 or newer series CPU.
*/
-int get_clocks_866 (void)
+int get_clocks(void)
{
volatile immap_t *immr = (immap_t *) CONFIG_SYS_IMMR;
char tmp[64];
diff --git a/common/board_f.c b/common/board_f.c
index 57e26d08cb..05b2b137f7 100644
--- a/common/board_f.c
+++ b/common/board_f.c
@@ -846,7 +846,7 @@ static const init_fnc_t init_sequence_f[] = {
/* TODO: can any of this go into arch_cpu_init()? */
#if defined(CONFIG_8xx_CPUCLK_DEFAULT)
/* get CPU and bus clocks according to the environment variable */
- get_clocks_866,
+ get_clocks,
/* adjust sdram refresh rate according to the new clock */
sdram_adjust_866,
init_timebase,
diff --git a/include/common.h b/include/common.h
index 6170422359..cdaeec8e42 100644
--- a/include/common.h
+++ b/include/common.h
@@ -640,7 +640,6 @@ int serial_stub_tstc(struct stdio_dev *sdev);
/* $(CPU)/speed.c */
int get_clocks (void);
-int get_clocks_866 (void);
int sdram_adjust_866 (void);
int adjust_sdram_tbs_8xx (void);
#if defined(CONFIG_MPC8260)
--
2.12.2.564.g063fe858b8-goog
More information about the U-Boot
mailing list