[U-Boot] [PATCH 3/8] dm: blk: Add a function to find the next block device number

Simon Glass sjg at chromium.org
Wed May 3 02:36:55 UTC 2017


Hi Andy,

On 24 April 2017 at 02:04, Andy Shevchenko <andy.shevchenko at gmail.com> wrote:
> On Mon, Apr 24, 2017 at 5:02 AM, Simon Glass <sjg at chromium.org> wrote:
>> At present this code is inline. Move it into a function to allow it to
>> be used elsewhere.
>>
>> Signed-off-by: Simon Glass <sjg at chromium.org>
>
>> +static int blk_next_free_devnum(enum if_type if_type)
>> +{
>> +       int ret;
>> +
>> +       ret = blk_find_max_devnum(if_type);
>> +       if (ret == -ENODEV)
>> +               return 0;
>
>> +       else if (ret < 0)
>
> Useless 'else'.
>
>> +               return ret;
>> +       else
>
> Ditto.
>
>> +               return ret + 1;
>> +}

I think it is clearer with these. At least, I would ask for them to be
added if they were missing.

What do you think of this series as a whole?

Regards,
Simon


More information about the U-Boot mailing list