[U-Boot] [RFC PATCH] gpio: zynq: Setup bank_name to dev->name

Stefan Herbrechtsmeier stefan at herbrechtsmeier.net
Fri Jul 20 19:31:40 UTC 2018


Hi Michal,

Am 12.07.2018 um 16:04 schrieb Michal Simek:
> There should be proper bank name setup to distiguish between different
> gpio drivers. Use dev->name for it.
>
> Signed-off-by: Michal Simek <michal.simek at xilinx.com>
> ---
>
>   drivers/gpio/zynq_gpio.c | 2 ++
>   1 file changed, 2 insertions(+)
>
> diff --git a/drivers/gpio/zynq_gpio.c b/drivers/gpio/zynq_gpio.c
> index 26f69b1a713f..f793ee5754a8 100644
> --- a/drivers/gpio/zynq_gpio.c
> +++ b/drivers/gpio/zynq_gpio.c
> @@ -337,6 +337,8 @@ static int zynq_gpio_probe(struct udevice *dev)
>   	struct zynq_gpio_privdata *priv = dev_get_priv(dev);
>   	struct gpio_dev_priv *uc_priv = dev_get_uclass_priv(dev);
>   
> +	uc_priv->bank_name = dev->name;
> +
>   	if (priv->p_data)
>   		uc_priv->gpio_count = priv->p_data->ngpio;
>   
Does this not lead to ugly names because the gpio number is append to 
the bank_name? Have you check the "gpio status -a" output?

Other drivers use the gpio-bank-name from the device tree.

Best regards
   Stefan




More information about the U-Boot mailing list