[U-Boot] [RFC PATCH] gpio: zynq: Setup bank_name to dev->name
Stefan Herbrechtsmeier
stefan at herbrechtsmeier.net
Mon Jul 23 18:29:38 UTC 2018
Hi Michal,
Am 23.07.2018 um 11:08 schrieb Michal Simek:
> On 20.7.2018 21:31, Stefan Herbrechtsmeier wrote:
>> Am 12.07.2018 um 16:04 schrieb Michal Simek:
>>> There should be proper bank name setup to distiguish between different
>>> gpio drivers. Use dev->name for it.
>>>
>>> Signed-off-by: Michal Simek <michal.simek at xilinx.com>
>>> ---
>>>
>>> drivers/gpio/zynq_gpio.c | 2 ++
>>> 1 file changed, 2 insertions(+)
>>>
>>> diff --git a/drivers/gpio/zynq_gpio.c b/drivers/gpio/zynq_gpio.c
>>> index 26f69b1a713f..f793ee5754a8 100644
>>> --- a/drivers/gpio/zynq_gpio.c
>>> +++ b/drivers/gpio/zynq_gpio.c
>>> @@ -337,6 +337,8 @@ static int zynq_gpio_probe(struct udevice *dev)
>>> struct zynq_gpio_privdata *priv = dev_get_priv(dev);
>>> struct gpio_dev_priv *uc_priv = dev_get_uclass_priv(dev);
>>> + uc_priv->bank_name = dev->name;
>>> +
>>> if (priv->p_data)
>>> uc_priv->gpio_count = priv->p_data->ngpio;
>>>
>> Does this not lead to ugly names because the gpio number is append to
>> the bank_name? Have you check the "gpio status -a" output?
> Yes I was checking it. Names are composed together but also just numbers
> works as before.
>
> gpio at ff0a00000: input: 0 [ ]
> gpio at ff0a00001: input: 0 [ ]
> gpio at ff0a00002: input: 0 [ ]
> gpio at ff0a00003: input: 0 [ ]
> gpio at ff0a00004: input: 0 [ ]
> gpio at ff0a00005: input: 0 [ ]
> gpio at ff0a00006: input: 0 [ ]
> gpio at ff0a00007: input: 0 [ ]
> gpio at ff0a00008: input: 0 [ ]
> gpio at ff0a00009: input: 0 [ ]
Do you think that this are meaningful names? It isn't possible to
separate the device and pin number as well as it mix hex and decimal
numbers.
> If you know better way how to setup a bank name please let me know but I
> need to distinguish ps gpio from pl one and for pl we need to know the
> address.
I know the use case.
A lot of drivers use the bank_name from the device tree, some drivers
append an underscore to the bank name and others add the req_seq of the
device to an alphabetic character.
>> Other drivers use the gpio-bank-name from the device tree.
> I can't see this property inside Linux kernel. If this has been reviewed
> by dt guys please let me know.
This property is only used by u-boot. I think it isn't needed by the
Linux kernel.
Best regards
Stefan
More information about the U-Boot
mailing list