[U-Boot] [PATCH 2/3] configs: Rename environment variable fit_loadaddr to addr_fit

Tom Rini trini at konsulko.com
Wed Aug 21 12:42:56 UTC 2019

On Mon, Aug 12, 2019 at 03:59:54PM -0400, Andrew F. Davis wrote:

> This is the first part of a larger effort I would like to propose to
> unify and simplify the default set of environment variables.
> When many early environment variables were named there were fewer images
> being loaded, usually just a kernel. At this time names like 'loadaddr'
> would suffice. Now we have more images and many more commands that act on
> them, often re-using the same variable for several different uses. The
> contents of a variable are also not immediately known causing one to have
> to look up a chain of variables to understand what a command is actually
> doing. I suggest the following.
> To start, all variables containing names should be prefixed with name_
> and addresses with addr_. This is like how K2 already does things and
> allows for simple universal commands like:
> get_fdt_nfs=nfs ${addr_fdt} /boot/${name_fdt}
> Which is very clear on what is intended here and would work across all
> board that using the this naming convention.
> We can do this one variable at a time, start here with addr_fit.
> Signed-off-by: Andrew F. Davis <afd at ti.com>
> Acked-by: Andreas Dannenberg <dannenberg at ti.com>

Applied to u-boot/master, thanks!

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <http://lists.denx.de/pipermail/u-boot/attachments/20190821/90d5ac60/attachment.sig>

More information about the U-Boot mailing list