[U-Boot] 5 dead BPI-M3 after one year of inactivity

MAYER Hans Hans.Mayer at iiasa.ac.at
Fri Oct 18 13:07:54 UTC 2019

Dear All, 

after watching this mailing list some days I am not sure if I am right here. 
But I will give it a try. Here my issue.

some years ago ( maybe almost 3 years ) I bought 5 Banana-Pi M3. They were running successfully all over the time. A little bit more than a year ago I replaced these M3 by M64 based on the fact that M64 is a little bit more powerful than M3. I shutdown the M3 and put them into a box. Some days ago I tried to boot one and I had to realize that all 5 of them are dead.
I did everything what came in my mind. I replaced the USB power supply, I replaced the cable. I wrote the SD card with a new image, I took also the old image, I wrote to a brand new SD card. Also tried the USB OTG plug for power instead the power jack I used always. But no way to bring it up.
It always the same. When I power on all 3 LEDs are going on. First the red, than the other two. On the serial console I can watch the boot process. And after about 4.5 seconds the LEDs are dark, and the console hangs. It's not always at the same boot step. Measuring the current it shows 0 mA power consumption. So it switched off itself. Only unplug/plug from/to power will repeat the boot process until it hangs again. When I hit the return key to stop autoboot I get a prompt and this stays forever.
In my opinion it could be that these devices lost some information for a successful boot. There are a lot of errors and information which sounds strange for me ( NOT find the head of uboot, blkcnt should not be 0 )  see full list below. As far as I understand there are also several parameter which can be changed. As I don't have a reference I do not know what should be inside. 

Another question, these devices have an 'uboot' botton on board. This is normally not used. But I couldn't find a useful information for what it is. 

I asked my question about dead M3 already in Banana-Pi's forum, but without success. If someone knows a source where I could find help be so kind and let me know. 

Any help is welcome. 

// Hans

sdcard 0 line count 0
[mmc]: mmc driver ver 2014-8-11 15:06:39
[mmc]: ***Try SD card 0***
[mmc]: SD/MMC Card: 4bit, capacity: 30528MB
[mmc]: vendor: Man 001b534d Snr 5090575d
[mmc]: product: 00000
[mmc]: revision: 1.0
[mmc]: ***SD/MMC 0 init OK!!!***
sdcard 0 init ok
ERROR! NOT find the head of uboot.
The size of uboot is 000d8000.
Succeed in loading uboot from sdmmc flash.
Ready to disable icache.
Jump to secend Boot.
[      0.312]

U-Boot 2011.09-rc1-00000-gfe0f876 (May 03 2016 - 13:13:31) Allwinner Technology 

[      0.321]version: 2.1.0
normal mode
[      0.401]pmbus:   normal or secure os
[      0.405]PMU: AXP81X
[      0.407]PMU: AXP81X found
bat_vol=0, ratio=100
[      0.413]PMU: dcdc2 900
[      0.415]PMU: pll1 1008 Mhz
AXI0=336 Mhz,PLL_PERIPH =1200 Mhz AHB1=200 Mhz, APB1=100 Mhz 
set power on vol to default
dcdc1_vol = 3300, onoff=1
dcdc2_vol = 900, onoff=1
dcdc3_vol = 900, onoff=1
dcdc4_vol = 900, onoff=1
dcdc6_vol = 900, onoff=1
aldo1_vol = 1800, onoff=0
aldo2_vol = 1800, onoff=1
aldo3_vol = 3000, onoff=1
eldo2_vol = 1800, onoff=0
dldo1_vol = 3300, onoff=0
dldo2_vol = 3300, onoff=0
dldo3_vol = 2500, onoff=1
dldo4_vol = 2800, onoff=0
fldo2_vol = 900, onoff=1
gpio0_vol = 3300, onoff=1
gpio1_vol = 3300, onoff=1
find power_sply to end
axp=axp81x, supply=dcdc1, vol=3300
reg addr=0x1c20b04, value=0xd, pmu_vol=3300
axp=axp81x, supply=dcdc1, vol=3300
reg addr=0x1c20b08, value=0xd, pmu_vol=3300
axp=axp81x, supply=dldo3, vol=1800
reg addr=0x1c20b0c, value=0x0, pmu_vol=1800
axp=axp81x, supply=dcdc1, vol=3300
reg addr=0x1c20b10, value=0xd, pmu_vol=3300
axp=axp81x, supply=dcdc1, vol=3300
reg addr=0x1c20b14, value=0xd, pmu_vol=3300
axp=axp81x, supply=dcdc1, vol=3300
reg addr=0x1c20b18, value=0xd, pmu_vol=3300
axp=axp81x, supply=dcdc1, vol=3300
reg addr=0x1c20b1c, value=0xd, pmu_vol=3300
axp=axp81x, supply=aldo3, vol=3000
reg addr=0x1f02f00, value=0xa, pmu_vol=3000
config gpio bias voltage finish
vbus not exist
no battery, limit to dc
ac100 reg 0x00 = 0x101
ac100 reg 0xd0 = 0x0
ac100 reg 0xd1 = 0x0
limit to 2500mA 
fel key old mode
run key detect
no key found
no key input
dram_para_set start
dram_para_set end
[      0.759]DRAM:  2 GiB
relocation Offset is: 75af7000
user_gpio config
user_gpio ok
gic: normal or no secure os mode
script config pll_de to 504 Mhz
script config pll_video1 to 297 Mhz
Not Found clk pll_video in script 
enable power vcc-hdmi-18, ret=0
DRV_DISP_Init end
[      0.924]boot_disp.output_disp=1
[      0.927]boot_disp.output_type=3
[      0.931]boot_disp.output_mode=5
[      0.934]fetch script data boot_disp.auto_hpd fail
disp1 device type(4) enable
attched ok, mgr1<-->device1, type=4, mode=5----
ready to set mode
workmode = 0
MMC:	 0
[      0.949][mmc]: mmc driver ver 2015-04-13 14:50:00
[      0.954][mmc]: get sdc_phy_wipe fail.
[      0.958][mmc]: get sdc0 sdc_erase fail.
[      0.962][mmc]: get sdc_f_max fail,use default 50000000Hz
[      0.967][mmc]: get sdc_ex_dly_used fail,use default dly
[      0.973][mmc]: SUNXI SD/MMC: 0
[      0.986][mmc]: *Try SD card 0*
[      1.019][mmc]: CID 0x1b534d30 0x30303030 0x10509057 0x5d00fb89
[      1.024][mmc]: mmc clk 50000000
[      1.028][mmc]: SD/MMC Card: 4bit, capacity: 30528MB
[      1.033][mmc]: boot0 capacity: 0KB,boot1 capacity: 0KB
[      1.038][mmc]: ***SD/MMC 0 init OK!!!***
[      1.042][mmc]: erase_grp_size:0x1WrBlk * 0x200 = 0x200 Byte
[      1.048][mmc]: secure_feature 0x0
[      1.051][mmc]: secure_removal_type  0x0
[      1.055]sunxi flash init ok
out of usb burn from boot: without usb
In:    serial
Out:   serial
Err:   serial
--------fastboot partitions--------
-total partitions:6-
-name-        -start-       -size-      
boot-res    : 1000000       2000000     
env         : 3000000       1000000     
boot        : 4000000       1000000     
rootfs      : 5000000       20000000    
klog        : 25000000      1000000     
UDISK       : 26000000      0           
base bootcmd=run setargs_nand boot_normal
bootcmd set setargs_mmc
key 0
recovery key high 10, low 8
cant find fstbt value
no misc partition is found
to be run cmd=run setargs_mmc boot_normal
serial is: 00000000000000000000
mount part name boot-res
cant open script.bin, maybe it is not exist
[      1.149]pre sys mode
[      1.280][mmc]: blkcnt should not be 0
[      1.299]fetch script data boot_disp.output_disp fail
[      1.304]screen_id =1, screen_width =1280, screen_height =720
[      1.309]frame buffer address 46400000
[      1.313]Hit any key to stop autoboot:  0 

More information about the U-Boot mailing list