[PATCH 08/21] dm: core: Rename ofnode_get_chosen_prop()

sjg at google.com sjg at google.com
Wed Feb 5 18:56:55 CET 2020

This function is actually intended to read a string rather than a
property. All of its current callers use it that way. Also there is no way
to return the length of the property from this function.

Rename it to better indicate its purpose, using ofnode_read as the prefix
since this matches most other functions.

Also add some tests which are missing for these functions.

Signed-off-by: Simon Glass <sjg at chromium.org>

 arch/sandbox/dts/test.dts                     |  2 ++
 .../puma_rk3399/puma-rk3399.c                 |  2 +-
 board/xilinx/common/board.c                   |  2 +-
 drivers/core/ofnode.c                         |  4 ++--
 include/dm/ofnode.h                           |  9 ++++----
 test/dm/ofnode.c                              | 21 +++++++++++++++++++
 6 files changed, 32 insertions(+), 8 deletions(-)

Applied to u-boot-dm, thanks!

More information about the U-Boot mailing list