[PATCH v3 00/20] Refactor the architecture parts of mt7628

Daniel Schwierzeck daniel.schwierzeck at gmail.com
Tue Feb 11 14:54:39 CET 2020

On Tue, Feb 11, 2020 at 11:58 AM Mauro Condarelli <mc5686 at mclink.it> wrote:
> Thanks Daniel.
> On 2/10/20 10:28 PM, Daniel Schwierzeck wrote:
> > Hi Mauro,
> >
> > Am 10.02.20 um 21:20 schrieb Mauro Condarelli:
> >> FYI
> >> I've been using this patchset for over a week without any adverse effect.
> >> It allowed me to port to VoCore2 board.
> >> Should I add a "Tested-by" flag?
> >> If so: how should I do it?
> >>
> >> Regards
> >> Mauro Codarelli
> >>
> > sorry that I could respond to your questions earlier. I've pushed the
> > complete patch set from Weijie to:
> >
> > https://gitlab.denx.de/u-boot/custodians/u-boot-mips/commits/testing
> I tried to use this repo/branch, but something is wrong (or I goofed badly).
> > Maybe this helps you with development. If you have a bootable patch set
> > (you can do MMC later) for your VoCore2 board, please submit a regular
> > patch series based on that branch so that we can review again.
> I *do* have a bootable patchset built on top of master + Nemirovsky
> "reconfigurable cpu clocks" + Weijie v3.
> Result is fully working, including net and mmc/SD.
> This patchset applies cleanly to uboot-mips/testing and compile
> apparently without errors, but resulting u-boot.bin does not work.
> By "does not work" I mean it does not utter a single char on debug
> serial.
> I tried to do a complete diff between my working tree and this
> non-working one and there are tons of differences, but I couldn't
> spot anything that might be relevant.
> I am unsure on how to proceed; please advise.

but do you reach the U-Boot prompt? If I apply your patch and build
it, I need to be able to program the resulting U-Boot image to SPI
flash and boot to U-Boot prompt. Also note that the final U-Boot image
with SPL is now called u-boot-mtmips.bin. Don't try to use u-boot.bin.

Regarding debug UART you also need to configure the serial driver with
"make menuconfig" (register base, clocks, baud rate etc.). There is no
driver model or device-tree involved at that point. I think Stefan
already told you the correct settings and you need this
board_early_init_f magic for the pinmux (don't forget to enable
CONFIG_BOARD_EARLY_INIT_F). But for the production mode debug UART
should be disabled anyway. SPL UART is different than debug UART.
AFAIU the regular driver model and device-tree stuff should work
there. For the pinmux you'll need the new CONFIG_SPL_UART2_SPIS_PINMUX
option. According to the code, you'll also need to configure

More information about the U-Boot mailing list