[PATCH] freescale: imx8mm_evk: Use IS_ENABLED instead of #ifdef
Tommaso Merciai
tomm.merciai at gmail.com
Sun Dec 26 18:23:11 CET 2021
Use IS_ENABLED(CONFIG_ENV_VARS_UBOOT_RUNTIME_CONFIG) to make the code
more readable and fix checkpatch.pl warning
Signed-off-by: Tommaso Merciai <tomm.merciai at gmail.com>
---
board/freescale/imx8mm_evk/imx8mm_evk.c | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/board/freescale/imx8mm_evk/imx8mm_evk.c b/board/freescale/imx8mm_evk/imx8mm_evk.c
index ab55135a97..e0975fcda7 100644
--- a/board/freescale/imx8mm_evk/imx8mm_evk.c
+++ b/board/freescale/imx8mm_evk/imx8mm_evk.c
@@ -60,9 +60,10 @@ int board_mmc_get_env_dev(int devno)
int board_late_init(void)
{
-#ifdef CONFIG_ENV_VARS_UBOOT_RUNTIME_CONFIG
- env_set("board_name", "EVK");
- env_set("board_rev", "iMX8MM");
-#endif
+ if (IS_ENABLED(CONFIG_ENV_VARS_UBOOT_RUNTIME_CONFIG)) {
+ env_set("board_name", "EVK");
+ env_set("board_rev", "iMX8MM");
+ }
+
return 0;
}
--
2.25.1
More information about the U-Boot
mailing list