[PATCH 09/49] dm: Rename DM_GET_DEVICE() to DM_DRVINFO_GET()
sjg at chromium.org
Wed Jan 6 16:13:05 CET 2021
On 12/29/20 12:34 AM, Simon Glass wrote:
> This does not get a device (struct udevice *) but a struct driver_info *
> so the name is confusing.
> Rename it accordingly. Since we plan to have several various of these
> macros, put GET at the end instead of the middle, so it is easier to spot
> the related macros.
> Signed-off-by: Simon Glass<sjg at chromium.org>
Reviewed-by: Walter Lozano <walter.lozano at collabora.com>
> doc/driver-model/of-plat.rst | 2 +-
> include/dm/platdata.h | 10 +++-------
> tools/dtoc/dtb_platdata.py | 4 ++--
> 3 files changed, 6 insertions(+), 10 deletions(-)
Applied to u-boot-dm/next, thanks!
More information about the U-Boot