[PATCH v2 29/50] Kconfig: Rename SPL_MD5_SUPPORT to SPL_MD5
Simon Glass
sjg at chromium.org
Thu May 6 16:24:17 CEST 2021
Drop the _SUPPORT suffix so we can use CONFIG_IS_ENABLED() with this
option.
Signed-off-by: Simon Glass <sjg at chromium.org>
---
(no changes since v1)
common/spl/Kconfig | 2 +-
include/image.h | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/common/spl/Kconfig b/common/spl/Kconfig
index 8cd41eb1b29..e6d00caaa85 100644
--- a/common/spl/Kconfig
+++ b/common/spl/Kconfig
@@ -418,7 +418,7 @@ config SPL_CRC32
for detected accidental image corruption. For secure applications you
should consider SHA1 or SHA256.
-config SPL_MD5_SUPPORT
+config SPL_MD5
bool "Support MD5"
depends on SPL_FIT
help
diff --git a/include/image.h b/include/image.h
index e68c2cbf621..e1e4bf6806f 100644
--- a/include/image.h
+++ b/include/image.h
@@ -47,7 +47,7 @@ struct fdt_region;
#include <linux/libfdt.h>
#include <fdt_support.h>
# ifdef CONFIG_SPL_BUILD
-# ifdef CONFIG_SPL_MD5_SUPPORT
+# ifdef CONFIG_SPL_MD5
# define IMAGE_ENABLE_MD5 1
# endif
# ifdef CONFIG_SPL_FIT_SHA1
--
2.31.1.607.g51e8a6a459-goog
More information about the U-Boot
mailing list