stm32f769-disco possibly broken ?

Xogium contact at
Wed Nov 17 10:27:01 CET 2021

I am trying to boot u-boot on stm32f769 discovery kit and having quite a lot of problems...

I am using the stm32f769-disco_defconfig without any sort of modification, building then copying u-boot.bin onto the internal flash of the board via st-link. I have triec both with openocd and with a simple cp, but none of them work.

The board remains completely silent over serial, and doesn't seem to be reactive at all.. I've tried some basic debug with openocd and gdb, but I don't get much if at all:

(gdb) target extended-remote :3333
Remote debugging using :3333
0x00003ffe in ?? ()
(gdb) print $pc
$1 = (void (*)()) 0x3ffe
(gdb) x $pc
0x3ffe: 0x00000000
Gdb thinks the stack is corrupted and only prints ? for each line when I try and do bt command, except the second line where it says signal handler call.

I have tried u-boot 2021.01, and u-boot from git master as of yesterday, commit 9272805139a104c83dff8230e03e9626dd9bc195.

Did anyone else experience this ? Alternatively, what else can I try to debug further ?


More information about the U-Boot mailing list