[PATCH v2 03/24] ata: Fix an instance of SPL_SATA_SUPPORT

Simon Glass sjg at chromium.org
Fri Aug 12 03:34:42 CEST 2022


The _SUPPORT suffix should be dropped. This happened because the rename
was applied around the same time as this new option, so did not include
renaming the new option.

The relevant commits are:

   f7560376ae sata: Rename SATA_SUPPORT to SATA
   73059529b2 ata: ahci-pci: Add new option CONFIG_SPL_AHCI_PCI

Fix it.

Signed-off-by: Simon Glass <sjg at chromium.org>
---

Changes in v2:
- Refer to a suffix, not a prefix

 drivers/ata/Kconfig | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/ata/Kconfig b/drivers/ata/Kconfig
index 7d2315bd4a2..70e6bd321a6 100644
--- a/drivers/ata/Kconfig
+++ b/drivers/ata/Kconfig
@@ -47,7 +47,7 @@ config SPL_AHCI_PCI
 	bool "Support for PCI-based AHCI controller for SPL"
 	depends on SPL
 	depends on SPL_PCI
-	depends on SPL_SATA_SUPPORT && DM_SCSI
+	depends on SPL_SATA && DM_SCSI
 
 config DWC_AHCI
 	bool "Enable Synopsys DWC AHCI driver support"
-- 
2.37.1.595.g718a3a8f04-goog



More information about the U-Boot mailing list